Bug 1414 - zsh doesn't work inside a gnome-terminal
zsh doesn't work inside a gnome-terminal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-03 18:34 EST by Pekka Pietikäinen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-09 17:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 1999-03-03 18:34:40 EST
When using zsh in gnome-terminal in 5.8.2 several
keybindingings don't work properly (eg. tab completion or
arrow keys, instead of doing something it just shows
what the key would normally do). gnome-terminal+bash is
fine, so is xterm+zsh or console+zsh.
Comment 1 Pekka Pietikäinen 1999-03-11 17:50:59 EST
Removing the setuid bit from gnome-pty-helper fixed the problem.
Basically the tty's got owned by root in /dev/pts so the user
didn't have the permission to access them.

Actually I don't think a gnome-pty-helper is needed at all with UNIX98
pty's. Also you could call the fact the tty gets shown as ttypX
instead of pts/X in utmp in gnome-terminal a bug (since the tty
really is a pts/X)
Comment 2 Owen Taylor 1999-06-09 17:40:59 EDT
These problems were fixed prior to 6.0.

Note You need to log in before you can comment on or make changes to this bug.