Bug 1414028 - Provide DRBD for EPEL
Summary: Provide DRBD for EPEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: drbd
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hanecak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 15:03 UTC by g.danti
Modified: 2020-08-06 11:33 UTC (History)
4 users (show)

Fixed In Version: drbd-9.13.1-1.el7 drbd-9.13.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-29 00:32:14 UTC
Type: Bug


Attachments (Terms of Use)

Description g.danti 2017-01-17 15:03:26 UTC
Description of problem:
DRBD is an extremely useful addition for replication tasks. While it is included by default on vanilla kernel >= 2.6.33, Red Hat decided to _not_ include it on their kernels, nor to include the required userland tools in their repositories. EPEL should fix that. Moreover it appears that in the past EL7 DRBD packages were available on fedoraproject [1], but they are now gone.
[1] https://koji.fedoraproject.org/koji/buildinfo?buildID=602541

Version-Release number of selected component (if applicable):

How reproducible:
After enabling EPEL, try searching for drbd using yum

Steps to Reproduce:
1. yum install epel-release
2. yum search drbd
3. the only packages found is 'drbdlinks' and 'collectd-drbd'

Actual results:
No drbd packages are found

Expected results:
drbd packages should be availables

Additional info:

Comment 1 Major Hayden 🤠 2017-01-17 15:06:06 UTC
The DRBD packages for EL7 are already available in ELRepo:

http://elrepo.org/tiki/drbd84-utils

I previously tried to get this into EPEL but I received a *ton* of negative feedback due to the ELRepo package conflict. If you have ideas on how to get around that, I'm all ears!

Comment 2 Scott Williams 2018-08-15 23:59:23 UTC
Note that they only have drbd8.4 on ELRepo, which is not the current stable release of drbd-9 - https://github.com/LINBIT/drbd-9.0

Comment 3 g.danti 2018-08-16 07:12:22 UTC
Please note that DRBD9 is a complete rewrite by Linbit, with increase scope and complexity and which is not as stable as the old 8.4.x releases. While would be great for EPEL to have *both* DRBD 8.4.x and 9.x in its repositories, I would especially press for the former (8.4.x) to be made available.

Comment 4 Fedora Admin XMLRPC Client 2020-04-06 16:51:53 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 5 Fedora Admin XMLRPC Client 2020-04-29 16:43:47 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 6 Fedora Update System 2020-06-13 04:58:01 UTC
FEDORA-EPEL-2020-0ef510a3b8 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-0ef510a3b8

Comment 7 Fedora Update System 2020-06-14 04:56:12 UTC
drbd-9.13.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-4f9d0c5b2a

Comment 8 Fedora Update System 2020-06-14 17:35:45 UTC
drbd-9.13.1-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-0ef510a3b8

Comment 9 Fedora Update System 2020-06-29 00:32:14 UTC
FEDORA-EPEL-2020-4f9d0c5b2a has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-06-29 01:19:56 UTC
FEDORA-EPEL-2020-0ef510a3b8 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Richard Neuboeck 2020-08-06 11:33:11 UTC
Thanks for adding the utility packages. What's still missing is the actual kernel module if I'm not mistaken. I ELRepo it's called kmod-drbd. Would it be possible to add that to EPEL too?


Note You need to log in before you can comment on or make changes to this bug.