Bug 1414061 - [RFE]Copy Automate Method does not allow user to specify class
Summary: [RFE]Copy Automate Method does not allow user to specify class
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Dave Johnson
URL:
Whiteboard: automate:ui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 16:05 UTC by Tina Fitzgerald
Modified: 2019-12-18 14:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 14:27:08 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Tina Fitzgerald 2017-01-17 16:05:49 UTC
Description of problem:
Copying an Automate method from one class to another class in the same domain does not allow the user to select the destination class. It only goes to the namespace level.


Steps to Reproduce:
1. Automate explorer -> create new domain.
2. Copy any automate method from ManageIQ domain to new writable domain, specifying copy to same path.
3. Copy any class except the class from step 2 from ManageIQ to new writable domain specifying copy to same path.
4. Attempt to copy the Automate method from step 2 in the writable domain to the new class created/copied in step 3. The selector only traverses to the namespace level. It should allow user to select class within the namespace to copy method.


Note You need to log in before you can comment on or make changes to this bug.