Bug 1414071 - systemd-journal-gatewayd doesn't work when /run/log/journal is re-created by systemd-journald
Summary: systemd-journal-gatewayd doesn't work when /run/log/journal is re-created by ...
Keywords:
Status: CLOSED DUPLICATE of bug 1411198
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1546552
TreeView+ depends on / blocked
 
Reported: 2017-01-17 16:43 UTC by Frantisek Sumsal
Modified: 2019-02-01 14:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-01 14:27:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1411198 0 unspecified CLOSED systemd-journald service should set up log storage properly 2021-02-22 00:41:40 UTC

Internal Links: 1411198

Description Frantisek Sumsal 2017-01-17 16:43:23 UTC
Description of problem:
When /run/log/journal is re-created by systemd-journald service (eg. by manually removing it and restarting mentioned service) systemd-journal-gatewayd doesn't return any data. This behavior can be fixed by issuing 'systemd-tmpfiles --create --prefix /run/log/journal' command. One possible cause is lack of correct permissions, when the /run/log/journal folder is re-created by systemd-journald.

Version-Release number of selected component (if applicable):
systemd-libs-219-30.el7_3.7.x86_64
systemd-sysv-219-30.el7_3.7.x86_64
systemd-journal-gateway-219-30.el7_3.7.x86_64
systemd-219-30.el7_3.7.x86_64

How reproducible:
always

Steps to Reproduce:
# yum -y install systemd-journal-gateway
# rm -fr /run/log/journal && systemctl restart systemd-journald
# mkdir /tmp/journal-gateway
# openssl req -x509 -sha256 -nodes  -newkey rsa:2048 -keyout /tmp/key.key -out /tmp/cert.pem -subj "/C=US/ST=Denial/L=Springfield/O=Dis/CN=www.example.com"
# echo "
ServerKeyFile=/tmp/key.key
ServerCertificateFile=/tmp/cert.pem
TrustedCertificateFile=/etc/ssl/certs/ca-bundle.trust.crt
" >> /etc/systemd/journal-remote.conf
# systemctl start systemd-journal-gatewayd.socket
# curl -H'Accept: application/vnd.fdo.journal' 'http://localhost:19531/entries?boot' -o remote.journal
# [ ! -s remote.journal ] && echo "ERROR - no data received" || head remote.journal
# echo -e "-------\n/run/log/journal ACL:"
# getfacl /run/log/journal

Actual results:
...
writing new private key to '/tmp/key.key'
-----
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
ERROR - no data received
-------
/run/log/journal ACL:
getfacl: Removing leading '/' from absolute path names
# file: run/log/journal
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

Expected results:
...
writing new private key to '/tmp/key.key'
-----
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  7698    0  7698    0     0  1516k      0 --:--:-- --:--:-- --:--:-- 1879k
__CURSOR=s=fc2a4d6158fe43508769f2e00fdcc474;i=1;b=932809724bcb43bba629f32e6a476cec;m=28ff0148e;t=5464cdc1c81c6;x=186cb41bbb2239cf
__REALTIME_TIMESTAMP=1484670807867846
__MONOTONIC_TIMESTAMP=11004810382
_BOOT_ID=932809724bcb43bba629f32e6a476cec
PRIORITY=6
_TRANSPORT=driver
MESSAGE=Runtime journal is using 8.0M (max allowed 91.9M, trying to leave 137.9M free of 911.1M available → current limit 91.9M).
MESSAGE_ID=ec387f577b844b8fa948f33cad9a75e6
_PID=14601
_UID=0
-------
/run/log/journal ACL:
getfacl: Removing leading '/' from absolute path names
# file: run/log/journal
# owner: root
# group: systemd-journal
# flags: -s-
user::rwx
group::r-x
other::r-x

Comment 4 David Tardon 2019-02-01 14:27:47 UTC

*** This bug has been marked as a duplicate of bug 1411198 ***


Note You need to log in before you can comment on or make changes to this bug.