Bug 1414084 - uploaded images using the GUI have actual_size=0
Summary: uploaded images using the GUI have actual_size=0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: 4.1.1
Assignee: Daniel Erez
QA Contact: Natalie Gavrielov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 17:16 UTC by Natalie Gavrielov
Modified: 2017-04-21 09:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:31:49 UTC
oVirt Team: Storage
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
logs: vdsm,daemon,proxy,engine, results for rest API and db query (3.77 MB, application/x-gzip)
2017-01-17 17:16 UTC, Natalie Gavrielov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71174 0 master MERGED core: TransferImage - update actual size 2017-01-26 10:06:56 UTC
oVirt gerrit 71240 0 ovirt-engine-4.1 MERGED core: TransferImage - update actual size 2017-01-26 13:03:06 UTC

Description Natalie Gavrielov 2017-01-17 17:16:22 UTC
Created attachment 1241896 [details]
logs: vdsm,daemon,proxy,engine,   results for rest API and db query

Description of problem:
Images that were uploaded using the GUI have actual_size = 0. 

Version-Release number of selected component (if applicable):
vdsm-4.19.1-1.el7ev.x86_64
ovirt-engine-4.1.0-0.4.master.20170111000229.git9ce0636.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upload an image using GUI (not 0MB size)
2. View actual size of the image rest api / db

Actual results:

Both rest api and engine db show the actual_size is 0

storage_id                 | f301c494-bf06-4557-8beb-ca2fac999bcb
image_guid                 | 73a41f93-27f0-49fb-996b-9151e7ee190d
actual_size                | 0

storage_id                 | 1064eb8c-329d-479f-9ae9-14d7bd97441e
image_guid                 | e1678ea7-82b7-4a18-a3f8-bf4950412497
actual_size                | 0

storage_id                 | f301c494-bf06-4557-8beb-ca2fac999bcb
image_guid                 | ffb5b428-f73d-49fc-96fd-004a5308d60c
actual_size                | 0

storage_id                 | 1064eb8c-329d-479f-9ae9-14d7bd97441e
image_guid                 | a04745ac-8e3a-4d47-ad75-79ff477aedc9
actual_size                | 0


Expected results:

actual_size ≠ 0.

Additional info:
* Tested both block and file storage domains, also tested both raw and qcow2 formats.
* Besides the wrong value I don't see an impact on the image behaviour.
For example I connected one of the images to a vm, and ran it (since I uploaded a disk with an OS installed and data).

Comment 1 Daniel Erez 2017-01-17 18:37:51 UTC
@Natalie - was it the same behavior in previous builds?

Comment 2 Natalie Gavrielov 2017-01-18 09:38:01 UTC
(In reply to Daniel Erez from comment #1)
> @Natalie - was it the same behavior in previous builds?

I honestly don't remember (there was not a specific test for this field)..
But I tried it out with 4.0.6.3-0.1.el7ev and it also shows actual size =0.

Comment 3 Yaniv Kaul 2017-01-18 11:38:44 UTC
Dup of https://bugzilla.redhat.com/show_bug.cgi?id=1364794 ?

Comment 4 Natalie Gavrielov 2017-01-18 15:38:57 UTC
(In reply to Yaniv Kaul from comment #3)
> Dup of https://bugzilla.redhat.com/show_bug.cgi?id=1364794 ?

In issue 1364794 you wrote that preallocated were ok..

from comment 0 in this bug:

> Additional info:
> * Tested both block and file storage domains, also tested both raw and qcow2 
> formats.

The actual size for raw images (preallocated) = 0.

It doesn't seem to be same issue

Comment 5 Natalie Gavrielov 2017-03-13 14:36:21 UTC
Verified, performed scenario described in comment 0 (both block and file, used raw and qcow2 images).

Used: rhevm-4.1.1.4-0.1.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.