Bug 1414090 - Timer units are updating files in /var/lib/systemd/timers/ which is not in /etc/rwtab
Summary: Timer units are updating files in /var/lib/systemd/timers/ which is not in /e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Leos Pol
URL:
Whiteboard:
Depends On: 1429931
Blocks: 74systemd
TreeView+ depends on / blocked
 
Reported: 2017-01-17 17:45 UTC by Andrew J. Schorr
Modified: 2017-08-01 07:31 UTC (History)
7 users (show)

Fixed In Version: initscripts-9.49.38-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1429931 (view as bug list)
Environment:
Last Closed: 2017-08-01 07:31:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2286 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2017-08-01 11:26:43 UTC

Description Andrew J. Schorr 2017-01-17 17:45:58 UTC
Description of problem:
The unbound-anchor.timer updates the file /var/lib/systemd/timers/stamp-unbound-anchor.timer, so shouldn't that be noted in /etc/rwtab.d/unbound, for example?

Version-Release number of selected component (if applicable):
unbound-libs-1.4.20-28.el7.x86_64


How reproducible:
Enable unbound and notice that /var/lib/systemd/timers/stamp-unbound-anchor.timer is touched every 24 hours.

Steps to Reproduce:
1. yum install unbound unbound-libs
2. systemctl start unbound.service
3. notice that /var/lib/systemd/timers/stamp-unbound-anchor.timer is touched every 24 hours

Actual results:
Not in /etc/rwtab.d/unbound

Expected results:
File should be in /etc/rwtab.d/unbound

Additional info:

Comment 1 Tomáš Hozza 🤓 2017-01-18 08:44:03 UTC
Hello.

As far as I can tell, the file must be created by systemd as a side effect of running timer units. I noticed, that the /var/lib/systemd/timers/ directory contains also files for other timer units. I think the directory itself should be in rwtab and the configuration should be rather shipped by systemd.

Note that the file is not created by Unbound directly.

Comment 3 Andrew J. Schorr 2017-01-18 13:30:40 UTC
Agreed. Thanks for fixing the component.

Comment 5 Jan Synacek 2017-03-09 08:44:51 UTC
After consulting this with lnykryn, we decided it would be best addressed in initscripts: https://github.com/fedora-sysv/initscripts/pull/65

Comment 7 Lukáš Nykrýn 2017-03-09 11:11:17 UTC
We just need to backport: https://github.com/fedora-sysv/initscripts/commit/73f52775e7c92c7428759d6d41b2d39bcce541ab

Comment 8 David Kaspar [Dee'Kej] 2017-03-24 16:17:09 UTC
Pull-request submitted:
https://github.com/fedora-sysv/initscripts/pull/84

Comment 13 Leos Pol 2017-05-29 06:47:32 UTC
initscripts-9.49.39-1.el7:
# grep /var/lib/systemd/timers /etc/rwtab
empty	/var/lib/systemd/timers

Comment 15 errata-xmlrpc 2017-08-01 07:31:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2286


Note You need to log in before you can comment on or make changes to this bug.