Bug 1414126 - UI error on 'wipe' and 'discard' being mutually exclusive is unclear and appears too late
Summary: UI error on 'wipe' and 'discard' being mutually exclusive is unclear and appe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.1.1
: 4.1.1
Assignee: Idan Shaby
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks: 1436160
TreeView+ depends on / blocked
 
Reported: 2017-01-17 20:31 UTC by Yaniv Kaul
Modified: 2017-04-21 09:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1436160 (view as bug list)
Environment:
Last Closed: 2017-04-21 09:38:43 UTC
oVirt Team: Storage
rule-engine: ovirt-4.1+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71278 0 master MERGED webadmin: add ui logic to WAD-EnableDiscard relationship 2021-01-19 02:15:32 UTC
oVirt gerrit 71843 0 ovirt-engine-4.1 MERGED webadmin: add ui logic to WAD-EnableDiscard relationship 2021-01-19 02:16:12 UTC

Description Yaniv Kaul 2017-01-17 20:31:20 UTC
Description of problem:
Only after 'OK' and trying to create a disk, I'm getting the following error:
"Cannot add Virtual Disk. The underlying storage of iscsi doesn't support securely discarding which is required by vm1_Disk1's wipe after delete property."

This is:
1. Unclear.
2. Dismisses the disk creation.

Any good reason it cannot be done before the OK? At least move the user back to the dialog so he can fix his wrongdoing.


Version-Release number of selected component (if applicable):
master.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tal Nisan 2017-01-18 08:13:46 UTC
Generally for simple validations that don't require too much data from the backend or more complicated logic duplication we do them in the UI (e.g. data center is lower than version X so we disable feature Y) while for validations that require more logic or querying more data we validate them in the validation part of the command after it has been executed and close the pop up for better user experience, this behavior exists in many of the other pop ups as well.

Idan, can you please check if it is feasible to validate the discard support within the client? If not we can maybe extract it to a validation backend query prior to running the command and closing the pop up, it makes no sense for the user to lose all the new disk data he entered just because of the discard

Comment 2 Raz Tamir 2017-04-04 13:01:39 UTC
When I'm trying to add a new disk to VM, the checkbox is grayed out and a message saying that the underlying storage is not supported discard.
This is not true because the fix depends on the storage domain discard flag enabled or not.
In my case, the storage domain's discard is disabled (the underlying storage supports discard) but still, the same message appears.

Idan, Should I reopen it? or you will submit another patch?

Comment 3 Raz Tamir 2017-04-04 13:25:12 UTC
After discussed with Idan, I will open a new bug

Comment 4 Raz Tamir 2017-04-09 22:13:04 UTC
Verified on rhevm-4.1.1.8-0.1.el7


Note You need to log in before you can comment on or make changes to this bug.