Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414148 - Device 'eGalax Inc. USB TouchController Pen' does not meet tablet criteria.
Summary: Device 'eGalax Inc. USB TouchController Pen' does not meet tablet criteria.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 21:46 UTC by Nicolas Chauvet (kwizart)
Modified: 2019-01-09 12:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-24 22:46:27 UTC
Type: Bug


Attachments (Terms of Use)
TouchScreen interaction on event3. (44.45 KB, text/plain)
2017-01-17 23:06 UTC, Nicolas Chauvet (kwizart)
no flags Details

Description Nicolas Chauvet (kwizart) 2017-01-17 21:46:33 UTC
Description of problem:
When running Fedora 25 on intel tablet EXOPG06411, I'm experiencing the following:
Device 'eGalax Inc. USB TouchController Pen' does not meet tablet criteria.

Version-Release number of selected component (if applicable):
libinput-1.5.901-1.fc25.x86_64
xorg-x11-drv-libinput-0.23.0-2.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot the Workstation Spin as Xorg on EXOPG06411
2.
3.

Actual results:
(II) config/udev: Adding input device eGalax Inc. USB TouchController (/dev/input/event3)
(**) eGalax Inc. USB TouchController: Applying InputClass "evdev touchscreen catchall"
(**) eGalax Inc. USB TouchController: Applying InputClass "libinput touchscreen catchall"
(II) Using input driver 'libinput' for 'eGalax Inc. USB TouchController'
(II) systemd-logind: got fd for /dev/input/event3 13:67 fd 27 paused 0
(**) eGalax Inc. USB TouchController: always reports core events
(**) Option "Device" "/dev/input/event3"
(**) Option "_source" "server/udev"
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is tagged by udev as: Touchscreen
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is a touch device
(**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1:1.0/0003:0EEF:72A1.0001/input/input3/event3"
(II) XINPUT: Adding extended input device "eGalax Inc. USB TouchController" (type: TOUCHSCREEN, id 9)
(**) Option "AccelerationScheme" "none"
(**) eGalax Inc. USB TouchController: (accel) selected scheme none/0
(**) eGalax Inc. USB TouchController: (accel) acceleration factor: 2.000
(**) eGalax Inc. USB TouchController: (accel) acceleration threshold: 4
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is tagged by udev as: Touchscreen
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is a touch device
(II) config/udev: Adding input device eGalax Inc. USB TouchController (/dev/input/mouse0)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device eGalax Inc. USB TouchController Pen (/dev/input/event4)
(**) eGalax Inc. USB TouchController Pen: Applying InputClass "evdev tablet catchall"
(**) eGalax Inc. USB TouchController Pen: Applying InputClass "libinput tablet catchall"
(**) eGalax Inc. USB TouchController Pen: Applying InputClass "libinput tablet catchall"
(**) eGalax Inc. USB TouchController Pen: Applying InputClass "libinput tablet catchall"
(II) Using input driver 'libinput' for 'eGalax Inc. USB TouchController Pen'
(II) systemd-logind: got fd for /dev/input/event4 13:68 fd 28 paused 0
(**) eGalax Inc. USB TouchController Pen: always reports core events
(**) Option "Device" "/dev/input/event4"
(**) Option "_source" "server/udev"
(II) input device 'eGalax Inc. USB TouchController Pen', /dev/input/event4 is tagged by udev as: Tablet
(EE) libinput bug: Device 'eGalax Inc. USB TouchController Pen' does not meet tablet criteria. Ignoring this device.
(II) input device 'eGalax Inc. USB TouchController Pen', /dev/input/event4 is a tablet
(II) failed to create input device '/dev/input/event4'.
(EE) libinput: eGalax Inc. USB TouchController Pen: Failed to create a device for /dev/input/event4
(EE) PreInit returned 2 for "eGalax Inc. USB TouchController Pen"
(II) UnloadModule: "libinput"
(II) systemd-logind: releasing fd for 13:68
(II) config/udev: Adding input device eGalax Inc. USB TouchController Pen (/dev/input/mouse1)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device HDA Intel Front Headphone (/dev/input/event9)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is tagged by udev as: Touchscreen
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is a touch device
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is tagged by udev as: Touchscreen
(II) input device 'eGalax Inc. USB TouchController', /dev/input/event3 is a touch device


Expected results:
It should probably consider the input method as a tablet.

Additional info:
The screen is sometime inverted. Using xrandr to rotate to 180° doesn't hold as the

Comment 1 Peter Hutterer 2017-01-17 22:36:14 UTC
please attach an evemu-record of an input sequence on this tablet. just a short pen stroke will do, thanks.

Comment 2 Nicolas Chauvet (kwizart) 2017-01-17 23:06:50 UTC
Created attachment 1241979 [details]
TouchScreen interaction on event3.


I was not able to create any interaction on event4.

Comment 3 Peter Hutterer 2017-01-17 23:25:38 UTC
event3 is the one that works though, and that's just a touchscreen and correctly detected. If you're not getting events from event4, that looks like it's a kernel problem then. There will be another problem which is where the error message comes from (the top bit of an evemu-record should help with identifying why) but until you get events from the kernel, this is moot anyway.

Comment 4 Nicolas Chauvet (kwizart) 2017-03-24 22:46:27 UTC
Seems like I haven't found the real message from my issue.


Note You need to log in before you can comment on or make changes to this bug.