Bug 1414158 - systemctl --user crashes
Summary: systemctl --user crashes
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 22:14 UTC by Philippe Troin
Modified: 2017-01-22 03:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-22 03:42:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Philippe Troin 2017-01-17 22:14:21 UTC
Description of problem:
Running systemctl --user crashes immediately.

Version-Release number of selected component (if applicable):
systemd-231-11.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run "systemctl --user"

Actual results:
% systemctl --user
Failed to list units: Process org.freedesktop.systemd1 exited with status 1
[1]    28986 exit 1     systemctl --user

Expected results:
I'd expect to see which units are running under the user systemd session.

Additional info:

Comment 1 Zbigniew Jędrzejewski-Szmek 2017-01-18 19:16:16 UTC
It looks like you systemd --user instance is not running.

What does "systemctl status user@`id -u`" show?

Comment 2 Philippe Troin 2017-01-22 03:42:44 UTC
Never mind, it got fixes with one of the recent updates.
Now systemctl --user is happy.


Note You need to log in before you can comment on or make changes to this bug.