Bug 1414195 - project display name inside angle brackets will be hidden when create app on external page
Summary: project display name inside angle brackets will be hidden when create app on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 02:01 UTC by XiaochuanWang
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Less than (<) and greater than (>) characters are valid within project display names, but inclusion of them in a way that mimics html (e.g., <displayname>) results in display names that do not appear in the choose existing project dropdown on the create from URL page. Consequence: Project display names that look like html do not appear in the choose existing project dropdown on the create from URL page. Fix: Escape < and > characters as HTML entities so that they display properly. Result: Strings that looks like HTML are now properly escaped and display as strings.
Clone Of:
Environment:
Last Closed: 2017-04-12 19:09:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
display name is <my display name> (25.05 KB, image/png)
2017-01-18 02:01 UTC, XiaochuanWang
no flags Details
display name is "my <display name>" (24.82 KB, image/png)
2017-01-18 02:02 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description XiaochuanWang 2017-01-18 02:01:23 UTC
Created attachment 1242018 [details]
display name is <my display name>

Description of problem:
Create a project with display name in angle brackets like "<my display name>". Go to external page like https://xxx:8443/console/create?tab=fromCatalog&name=nodejs-ex&imageStream=nodejs&imageTag=4. Click drop down list and the project "<my display name>" is missing

Version-Release number of selected component (if applicable):
v3.5.0.5+8f2840d

How reproducible:
Always

Steps to Reproduce:
1. Create a project with: *name is "myproject", *Display Name is "<my display name>"
2. Go to external page to create app:
Eg. https://xxx:8443/console/create?tab=fromCatalog&name=nodejs-ex&imageStream=nodejs&imageTag=4
3. From "Choose Existing Project" drop down list, check the projects
4. Create another project with: *name is "myproject", *Display Name is "my <display name>"
5. Go to the external page by step2 and check the drop down list again

Actual results:
3. Content inside angle brackets is missing.  
5. The "<display name>" is missing from the drop down list, only left "my", the new created project is actually exist.
Please see the screenshot.

Expected results:
3&5. Content inside angle brackets should be shown. 


Additional info:

Comment 1 XiaochuanWang 2017-01-18 02:02:02 UTC
Created attachment 1242019 [details]
display name is "my <display name>"

Comment 2 Robb Hamilton 2017-01-18 16:26:48 UTC
This is an issue with ui-select (the Angular directive we're using to create the dropdown picker).  See https://github.com/angular-ui/ui-select/issues/846.  I'm trying to determine how to workaround.

Comment 3 Robb Hamilton 2017-01-18 19:36:33 UTC
PR to resolve:  https://github.com/openshift/origin-web-console/pull/1135

Comment 4 Robb Hamilton 2017-01-19 18:47:06 UTC
New PR to resolve replacing the previous one:  https://github.com/openshift/origin-web-console/pull/1145

Comment 5 Troy Dawson 2017-01-27 17:46:50 UTC
This has been merged into ocp and is in OCP v3.5.0.10 or newer.

Comment 6 Yanping Zhang 2017-02-03 02:56:25 UTC
Checked on OCP v3.5.0.14, create projects with Display Name "<my display name>" and "my <display name>", when create app from external page, all project are list correctly in "Choose Existing Project" drop down list and can be chosen.
The bug has been fixed, so move it to Verified.

Comment 8 errata-xmlrpc 2017-04-12 19:09:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.