Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414228 - atd: fix the ownership of /var/spool/at & /var/spool/at/spool
Summary: atd: fix the ownership of /var/spool/at & /var/spool/at/spool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: at
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: beta
: 7.5
Assignee: Tomas Mraz
QA Contact: Radka Skvarilova
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-01-18 05:49 UTC by Awez
Modified: 2021-06-10 11:50 UTC (History)
4 users (show)

Fixed In Version: at-3.1.13-23.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 11:47:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0734 0 None None None 2018-04-10 11:47:58 UTC

Description Awez 2017-01-18 05:49:29 UTC
Description of problem: 


Version-Release number of selected component (if applicable):

rhel6.x
at-3.1.10-48.el6.x86_64


How reproducible:
                 easily, see below


Steps to Reproduce:

1. Check /var/spool/at and /var/spool/at/spool directory ownership



Actual results:

 [root@srv2-rhel6 ~]# ls -ld /var/spool/at 
 drwx------. 3 daemon daemon 29 May 23  2016 /var/spool/at

 [root@srv2-rhel6 ~]# ls -ld /var/spool/at/spool 
 drwx------. 2 daemon daemon 6 May 23  2016 /var/spool/at/spool

 [root@srv2-rhel6 ~]# man atd
 ...
 FILES
        /var/spool/at The directory for storing jobs; this should be mode 700, owner root.

        /var/spool/at/spool The directory for storing output; this should be mode 700, owner root.
 ...




Expected results:

man page entry should be corrected.
 /var/spool/at and /var/spool/at/spool owner should be 'daemon' not 'root'


Additional info:

 [root@srv2-rhel6 ~]# rpm -q --scripts -f /var/spool/at/
 postinstall scriptlet (using /bin/sh):
 touch /var/spool/at/.SEQ
 chmod 600 /var/spool/at/.SEQ
 chown daemon:daemon /var/spool/at/.SEQ                        <<<<<<<<<<<<<<<<<< 
 # must be in chkconfig on
 /sbin/chkconfig --add atd
 preuninstall scriptlet (using /bin/sh):
 if [ "$1" = "0" ] ; then
	 /sbin/service atd stop >/dev/null 2>&1 ||:
 	 /sbin/chkconfig --del atd
 fi
 postuninstall scriptlet (using /bin/sh):
 if [ "$1" -ge "1" ]; then
	 /sbin/service atd condrestart >/dev/null 2>&1 ||:
 fi


script is changing the ownership.

Comment 18 errata-xmlrpc 2018-04-10 11:47:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0734


Note You need to log in before you can comment on or make changes to this bug.