Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414237 - [GSS][RFE] Extended attributes on bricks present even when gluster volume create command fails
Summary: [GSS][RFE] Extended attributes on bricks present even when gluster volume cre...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.1
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: ---
Assignee: Atin Mukherjee
QA Contact: Byreddy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 06:43 UTC by Abhishek Kumar
Modified: 2020-02-14 18:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-24 05:32:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Abhishek Kumar 2017-01-18 06:43:47 UTC
Description of problem:
Extended attributes on bricks present even when gluster volume create command fails

Version-Release number of selected component (if applicable):
glusterfs-server-3.7.9-12.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Create a volume using one correct brick path(/brick1/b1) & 1 wrong brick path(/brick2/b10).
2.gluster volume create command will fail due to wrong brick path
3.Try to run again gluster volume create command with correct brick paths (/brick1/b1) & (/brick2/b2)

Actual results:
gives error for correct brick path in step one bricks like "/brick1/b1 is already part of a volume".

Expected results:
Gluster should roll-back all the xattrs set on bricks if gluster volume create command fails

Additional info:
We can over-ride this issue with use of 'force' in gluster volume create command but that will lead to further consequences by overlooking some other prerequisite,so it doesn't seem to be a good work around.

Comment 4 Atin Mukherjee 2017-02-24 05:32:09 UTC
I am closing this bug given the respective customer case is closed.


Note You need to log in before you can comment on or make changes to this bug.