Bug 1414238 - Screen glitches on Lenovo T460 and Carbon X1 4th Generation
Summary: Screen glitches on Lenovo T460 and Carbon X1 4th Generation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 7.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lyude
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1472339 1473733
TreeView+ depends on / blocked
 
Reported: 2017-01-18 06:47 UTC by Deepu K S
Modified: 2020-12-14 08:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-19 15:22:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
db2-client-t460skylake-glitch1.png (22.44 KB, image/png)
2017-01-18 06:54 UTC, Deepu K S
no flags Details
db2-client-t460skylake-glitch2.png (12.96 KB, image/png)
2017-01-18 06:54 UTC, Deepu K S
no flags Details
glicht2.jpg (468.66 KB, image/jpeg)
2017-01-18 06:55 UTC, Deepu K S
no flags Details
glitch.jpg (448.42 KB, image/jpeg)
2017-01-18 06:55 UTC, Deepu K S
no flags Details

Description Deepu K S 2017-01-18 06:47:40 UTC
Description of problem:
On Intel skylake models like the Lenovo T460 and the Carbon X1 4th Generation there are screen glitches on RHEL7.3.
This seems to be related to the Intel video driver.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Workstation release 7.3
kernel-3.10.0-514.2.2.el7.x86_64
xorg-x11-drv-intel-2.99.917-22.20151206.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Attached screenshots of glitches.

Expected results:
No glitches seen.

Additional info:

Comment 1 Deepu K S 2017-01-18 06:54:37 UTC
Created attachment 1242038 [details]
db2-client-t460skylake-glitch1.png

Comment 2 Deepu K S 2017-01-18 06:54:57 UTC
Created attachment 1242039 [details]
db2-client-t460skylake-glitch2.png

Comment 3 Deepu K S 2017-01-18 06:55:17 UTC
Created attachment 1242040 [details]
glicht2.jpg

Comment 4 Deepu K S 2017-01-18 06:55:41 UTC
Created attachment 1242042 [details]
glitch.jpg

Comment 5 Deepu K S 2017-01-18 07:00:50 UTC
# lspci | grep -i VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 520 [8086:1916] (rev 07) (prog-if 00 [VGA controller])

Kindly let us know if any further information needed.

Comment 10 Martin Kopal 2017-04-18 11:23:47 UTC
what sort of info is needed? we can help and answer questions since we have reported this. RH case id #01773506

Comment 14 Lyude 2017-08-21 20:24:16 UTC
A note for anyone trying to reproduce this bug so you don't have to spend the two hours I did trying to: for whatever reason this bug seems to be a lot more likely to happen on high resolution displays. Sometimes it doesn't even appear on 1080p displays, but it doesn't take long to make it happen on 4K.

Comment 15 Lyude 2017-08-21 21:35:02 UTC
(In reply to Lyude from comment #14)
> A note for anyone trying to reproduce this bug so you don't have to spend
> the two hours I did trying to: for whatever reason this bug seems to be a
> lot more likely to happen on high resolution displays. Sometimes it doesn't
> even appear on 1080p displays, but it doesn't take long to make it happen on
> 4K.

OK. This is a seriously tough bug to reproduce. But I think I've finally nailed down a reproduction recipe on this machine that makes it happen pretty reliably with slack. + xorg-x11-drv-intel:

- ignore what I said about 4K, the monitor resolution doesn't seem to have anything to do with it
- Maximize the window, this seems to increase the likelihood of it happening
- Zoom in (CTRL + "+") to 150% in slack. The higher the zoom, the more likely it is to happen. At or below 100% zoom, the bug seems to stop occurring on my machine.
- Scroll very slowly up and down chat buffers, random lines will start appearing all over the place between frames.

I have no idea why these are the steps I've been having to take to make this work, since that doesn't seem to be what anyone is doing on their machines in the videos that have been posted here. I don't use slack at all though, so it might be related to the fact there's far less open chat buffers and the like on my machine.

Additionally, I think that using gnome-shell might have something to do with it. In the videos I can see you guys don't seem to actually be using gnome, i wouldn't be entirely surprised if this happens more outside of gnome.

Anyway: going to try to figure out what's broken in xorg-x11-drv-intel now that I've got a reproducer.

Hopefully this will help me actually figure out what's going wrong here and allow QA to actually reproduce this on their machines.

Comment 16 Lyude 2017-08-22 16:59:41 UTC
Cool, so I've created a test RPM with a backported fix for this issue. This solves the problem on my end:

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=13905728

Partner managers, could you forward this to the customer and let us know if this fixes your issues?

Comment 28 Lyude 2017-10-19 15:22:53 UTC
Customer says upgrading to RHEL 7.4 fixed their problem, closing.


Note You need to log in before you can comment on or make changes to this bug.