Bug 1414257 - TypeError: unbound method checkOptions() must be called with IostatOptions instance as first argument (got MetricGroupManager instance instead)
Summary: TypeError: unbound method checkOptions() must be called with IostatOptions in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcp
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nathan Scott
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 07:50 UTC by Miloš Prchlík
Modified: 2017-03-21 11:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-21 11:21:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0735 0 normal SHIPPED_LIVE pcp bug fix update 2017-03-21 12:43:59 UTC

Description Miloš Prchlík 2017-01-18 07:50:22 UTC
Description of problem:

When running upstream test cases 536 or 842, both fail because of the following error:

> Traceback (most recent call last):
>   File "/usr/bin/pmiostat", line 214, in <module>
>     if not IostatOptions.checkOptions(manager):
> TypeError: unbound method checkOptions() must be called with IostatOptions instance as first argument (got MetricGroupManager instance instead)


Version-Release number of selected component (if applicable):

pcp-3.10.9-8.el6.i686


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nathan Scott 2017-01-18 08:45:25 UTC
Hi Miloš,

Fixed by the upstream commit below, looks like an easy one to backport.


commit 83b7b4fff6580d924073968cb8a5b717d329eb16
Author: Mark Goodwin <mgoodwin@redhat.com>
Date:   Thu Feb 11 14:56:03 2016 +1100

    pmiostat: correctly use a class instance of IostatOptions to check args
    
    Use an instance of IostatOptions to check args. This fixes a coding issue
    with older python versions (e.g. python 2.6.6 on RHEL6), and QA breakage.

Comment 4 Miloš Prchlík 2017-01-28 12:40:34 UTC
Verified with build pcp-3.10.9-9.el6.

Comment 6 errata-xmlrpc 2017-03-21 11:21:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0735.html


Note You need to log in before you can comment on or make changes to this bug.