Bug 1414292 - It will reboot automatically when entering RHVH boot entry for the first time after installation
Summary: It will reboot automatically when entering RHVH boot entry for the first time...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.1.0-rc
: 4.1
Assignee: Ryan Barry
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 09:17 UTC by Qin Yuan
Modified: 2017-02-01 14:38 UTC (History)
13 users (show)

Fixed In Version: imgbased-0.9.5-0.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:38:37 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
/var/log/*, /tmp/* (224.21 KB, application/x-gzip)
2017-01-18 09:17 UTC, Qin Yuan
no flags Details
sosreport (317.54 KB, application/x-xz)
2017-01-18 13:47 UTC, Qin Yuan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 70757 0 None None None 2017-01-18 15:00:42 UTC

Description Qin Yuan 2017-01-18 09:17:35 UTC
Created attachment 1242091 [details]
/var/log/*, /tmp/*

Description of problem:
Install RHVH 4.1, reboot and enter the system boot entry, it will reboot automatically during the booting up process.
There are error messages as below:

*** Warning -- SELinux targeted policy relabel is required.
*** Relabeling could take a very long time, depending on file
*** system size and speed of hard drives.
Warning: Skipping the following R/O filesystems:
/sys/fs/cgroup
Error getting authority: Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)
[   54.576623] watchdog watchdog0: watchdog did not stop!

After this auto reboot, it can enter RHVH system as usual.
This abnormal auto reboot only occurs at the first time entering RHVH boot entry after installation.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-20170116.0
imgbased-0.9.4-0.1.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170116.0
2. Reboot and enter RHVH 4.1 boot entry


Actual results:
1. After step2, it will print error messages described above and reboot automatically.

Expected results:
1. After step2, it can log in to RHVH 4.1 system successfully.

Additional info:

Comment 1 Sandro Bonazzola 2017-01-18 12:20:24 UTC
Can you please attach the report generated by "sosreport -o rpm"?
Thanks

Comment 2 Qin Yuan 2017-01-18 13:47:56 UTC
Created attachment 1242165 [details]
sosreport

Comment 3 Ryan Barry 2017-01-18 13:54:16 UTC
This is a side effect of https://gerrit.ovirt.org/#/c/70049/

Since the selinux bugs were very recently confirmed to be part of/fixed in platform code (we made no changes), this can be reverted.

Comment 4 Qin Yuan 2017-01-25 03:35:05 UTC
Test Versions:
redhat-virtualization-host-4.1-20170120.0
imgbased-0.9.6-0.1.el7ev.noarch

Test Steps:
1. Install redhat-virtualization-host-4.1-20170120.0
2. Reboot and enter RHVH boot entry

Test Results:
After step 2, it can enter RHVH system successfully without automatic reboot.

The bug is fixed, set the status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.