Bug 1414296 - Wrong password can't be cleared automatically after clicking "ok" of authentication failed dialog for spice guest
Summary: Wrong password can't be cleared automatically after clicking "ok" of authenti...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 09:20 UTC by mxie@redhat.com
Modified: 2019-06-15 18:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-15 18:42:35 UTC


Attachments (Terms of Use)
virt-manager-debug (13.12 KB, text/plain)
2017-01-18 09:20 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2017-01-18 09:20:23 UTC
Created attachment 1242093 [details]
virt-manager-debug

Description of problem:
Wrong password can't be cleared automatically after clicking "ok" of authentication failed dialog for spice guest

Version-Release number of selected component (if applicable):
virt-manager-1.4.0-2.el7.noarch
libvirt-2.0.0-10.el7_3.4.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.3

How reproducible:
100%

Steps to Reproduce:
1. Prepare a spice guest with password setting in virt-manager
2. Open the guest console and type wrong password, will pop up error "Viewer authentication error: Authentication failed: password is required"
3. Click "ok" for Authentication failed dialog, but the wrong password can't be cleared automatically


Actual results:
As subject

Expected results:
Wrong password can be cleared automatically after clicking "ok" of authentication failed dialog for spice guest

Additional info:
1.Wrong password can be cleared automatically after clicking "ok" of authentication failed dialog for VNC guest

Comment 1 Pavel Hrdina 2017-01-20 13:15:14 UTC
Moving to upstream, this is a minor inconvenience.

Comment 2 Cole Robinson 2019-06-15 18:42:35 UTC
I can't reproduce this anymore upstream so I think it's been fixed. The password screen stays visible, but a different error dialog pops up mentioning wrong password


Note You need to log in before you can comment on or make changes to this bug.