Bug 141433 - cdrecord -scanbus broken with ide-scsi
cdrecord -scanbus broken with ide-scsi
Status: CLOSED DUPLICATE of bug 134822
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 21:21 EST by Michael A. Peters
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2004-11-30 21:21:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Until the ide drivers allow me to succesfully check a burned image (dd
|md5sum) I have to use ide-scsi.

cdrecord -scanbus is broken with ide-scsi module
I've tried with two kernels.

grub boot info:

title Fedora Core SCSI (2.6.9-1.681_FC3)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-1.681_FC3 ro root=LABEL=/1 hdc=ide-scsi
        initrd /initrd-2.6.9-1.681_FC3.img

title Fedora Core SCSI (2.6.9-1.678_FC3)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-1.678_FC3 ro root=LABEL=/1 hdc=ide-scsi
        initrd /initrd-2.6.9-1.678_FC3.img


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cdrecord -scanbus
2.
3.
    

Actual Results:  Depends upon the moon phase what it actually produces.

[root@devel ~]# cdrecord --scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) '07) *
DA' 'PTEC ' 'ACB-5500' '    ' Communication
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
[root@devel ~]# cdrecord --scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) 'ADAPTEC ' 'ACB-5500        ' 'FAKE' NON CCS Disk
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
[root@devel ~]# cdrecord --scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) '���'
'���' '���' Removable
unknown device type 0x1f
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
[root@devel ~]# cdrecord --scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) '' '' '' NON CCS Disk
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
[root@devel ~]# 

Expected Results:  some consistant output would be nice for starters ...

Additional info:

only relevent info from dmesg that I could see

EXT3-fs: mounted filesystem with ordered data mode.
Adding 524120k swap on /dev/hda6.  Priority:-1 extents:1
ide-scsi is deprecated for cd burning! Use ide-cd and give
dev=/dev/hdX as device
scsi1 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: SONY      Model: CD-RW  CRX140E    Rev: 1.0n
  Type:   CD-ROM                             ANSI SCSI revision: 02
sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
Attached scsi CD-ROM sr0 at scsi1, channel 0, id 0, lun 0

doesn't look out of norm

NOTE - not running tainted kernel (I was with my last bug report, and
it was nvidias fault, not running it anymore)
Comment 1 Harald Hoyer 2004-12-01 06:19:17 EST
dup of #134822

*** This bug has been marked as a duplicate of 134822 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.