Bug 1414344 - Wrong message after regeneration kickstart file
Summary: Wrong message after regeneration kickstart file
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Bocek
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 10:21 UTC by Tereza Cerna
Modified: 2017-03-11 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-03-11 17:20:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 4 Alois Mahdal 2017-03-10 03:09:18 UTC
I cannot reproduce this.

This was originally found in 2.2.1-1.el5.  On el6 channel, the last version is 2.1.10-6.el6, so my guess is that the problematic code was never released.

Michal, can you please confirm if that is the case?  If so, I would propose dropping this from erratum and closing it (there is nothing to fix from RHEL6 customer POV).  Otherwise, please provide hint how to reproduce this on RHEL6.

Comment 5 Michal Bocek 2017-03-10 16:07:43 UTC
Alois, to reproduce this in 2.1.10-6.el6, make sure you have "autopart" in /root/anaconda-ks.cfg - it serves as a basis for the generated kickstart.

When generating kickstart the "part" commands were always added no matter whether there was "autopart" already or not.

Comment 6 Alois Mahdal 2017-03-10 18:03:03 UTC
Sorry, this does not work: 2.1.10 still passes, no errors seen.

(It did work for bug 1414341, where I have asked very similar question; sorry if I made it confusing.)

Comment 7 Michal Bocek 2017-03-11 17:20:55 UTC
Ok, it's possible that this bug, describing different results when executing the same command twice, is related to a development version of the Preupgrade Assistant. I have no other ideas on how to reproduce it. I'll close and drop it from the Erratum.


Note You need to log in before you can comment on or make changes to this bug.