Bug 1414377 - OpenStack VM Console returns with an argument error
Summary: OpenStack VM Console returns with an argument error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: GA
: 5.8.0
Assignee: Dávid Halász
QA Contact: Oleksandr Kolisnyk
URL:
Whiteboard:
: 1420919 (view as bug list)
Depends On:
Blocks: 1414885 1415544
TreeView+ depends on / blocked
 
Reported: 2017-01-18 11:26 UTC by Dávid Halász
Modified: 2017-06-12 16:39 UTC (History)
13 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1414885 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:39:55 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Dávid Halász 2017-01-18 11:26:45 UTC
Description of problem:
If requesting a VM Console for an OpenStack instance, the server returns with a 'wrong number of arguments' error.

Version-Release number of selected component (if applicable):
5.7.0.17

How reproducible:


Steps to Reproduce:
1. Have an OpenStack cloud/infra provider
2. Go to the summary page of a running vm/instance 
3. Click on the HTML5 remote console button

Actual results:
Console access failed: wrong number of arguments (given 2, expected 3)

Expected results:
It should open a new window with a noVNC remote console.

Additional info:

Comment 3 CFME Bot 2017-01-18 19:56:29 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/db1782916eed78d19846a3d274b71e4e8d552e3a

commit db1782916eed78d19846a3d274b71e4e8d552e3a
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Wed Jan 18 11:22:53 2017 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Wed Jan 18 12:27:47 2017 +0100

    Added missing parameter when requesting OpenStack remote console
    
    Fixes the 'wrong number of arguments' error
    https://bugzilla.redhat.com/show_bug.cgi?id=1414377

 .../manageiq/providers/openstack/cloud_manager/vm/remote_console.rb     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 5 Tzu-Mainn Chen 2017-02-10 02:16:49 UTC
*** Bug 1420919 has been marked as a duplicate of this bug. ***

Comment 6 arkady kanevsky 2017-02-10 02:24:11 UTC
When is release date of 4.2.1?

Comment 7 Oleksandr Kolisnyk 2017-05-16 14:11:25 UTC
Verified on 5.8.0.13-rc2 and RHOS 10


Note You need to log in before you can comment on or make changes to this bug.