Bug 1414385 - lftp mirror fails over TLS in all versions since lftp-4.0.9-6.el6 [NEEDINFO]
Summary: lftp mirror fails over TLS in all versions since lftp-4.0.9-6.el6
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lftp
Version: 6.8
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Michal Ruprich
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 11:46 UTC by Tim Ashby
Modified: 2017-12-06 10:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 10:23:04 UTC
Target Upstream Version:
mruprich: needinfo? (tashby)


Attachments (Terms of Use)

Description Tim Ashby 2017-01-18 11:46:53 UTC
lftp mirror command over https fails with the following error in all versions since lftp-4.0.9-6.el6:

gnutls_record_recv: A TLS packet with unexpected length was received; assuming EOF


lftp-4.0.9-6.el6.x86_64 = NOT AFFECTED

It looks like all versions newer than this are affected. However:

4.0.9-6.el6_8.4 = CONFIRMED BROKEN

Run the following command:

/usr/bin/lftp  -c '; mirror -c -P -v -v -v -e -I *.rpm -X "/headers/" -X "/repodata/" -X "*.src.rpm" -X "/SRPMS/" -X "*-debuginfo-*.rpm" -X "/debug/" https://myreposerver/repo /mrepo/reponame'


Actual results:

gnutls_record_recv: A TLS packet with unexpected length was received; assuming EOF


Expected results:

Remote URL to be mirrored locally without error

Additional info:

lftp gets stuck in a reconnect loop and repeatedly erroring out as above

Comment 4 Michal Ruprich 2017-10-05 12:26:14 UTC
Hi Tim, I was unable to reproduce this. If this issue still persists, could you please run it with the '-d' option(/usr/bin/lftp  -d -c '; mirror...)  and upload the output?

Thanks.

Comment 6 Jan Kurik 2017-12-06 10:23:04 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.