Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414418 - Patternfly Check Boxes and Radio Buttons text should be clickable
Summary: Patternfly Check Boxes and Radio Buttons text should be clickable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.2
: 4.1.2
Assignee: Alexander Wels
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 12:57 UTC by Eldan Hildesheim
Modified: 2017-05-23 08:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-23 08:11:23 UTC
oVirt Team: UX
rule-engine: ovirt-4.1+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71104 0 master MERGED webadmin: Fix label click on checkbox. 2017-02-14 18:08:33 UTC
oVirt gerrit 72305 0 ovirt-engine-4.1 MERGED webadmin: Fix label click on checkbox. 2017-02-14 22:26:27 UTC
oVirt gerrit 73075 0 master MERGED webadmin: Fix clicking on labels 2017-02-27 16:51:18 UTC
oVirt gerrit 73175 0 ovirt-engine-4.1 MERGED webadmin: Fix clicking on labels 2017-02-28 10:49:06 UTC

Description Eldan Hildesheim 2017-01-18 12:57:34 UTC
Description of problem:
Patternfly was introduced to new Host and new VM dialogue.
Normally when clicking on a text next to a radio button, the result should toggle the Radiobutton as well as clicking on the radio button it self.
Same for CheckBoxes.
In the 2 Dialogues above this is not consistent.
This will confuse the user since he will think the option is disable.



Version-Release number of selected component (if applicable):


How reproducible:
4.2

Steps to Reproduce:
1. open new/ edit VM dialogue
2. left tab: system
3. click the text: "Provide custom serial number policy"
4. there are many examples like this in each dialogue.


Expected results:
Insert the text INSIDE the component

*This bug is similar to bug: 1402343

Comment 1 Radim Hrazdil 2017-02-20 09:59:03 UTC
Verified that "Provide custom serial number policy" is text-clickable in version 4.1.1.2-0.1.el7.

Comment 2 Radim Hrazdil 2017-02-20 12:14:31 UTC
After further investigation I have discovered there are several more occurrences of this issue.

1. 
Virtual Machines -> New VM -> Host (on the left) -> "Specific Hosts" – radio button is not text-clickable.

2.
Hosts -> New -> General -> click use Foreman/Satellite -> "Discovered Hosts/Provisioned" -- options are not text-clickable.

3.
Hosts -> New -> Console -> "Override display address" is not text-clickable. Also the text is very far from the checkbox, as it almost wasn't related.

Comment 3 Red Hat Bugzilla Rules Engine 2017-02-20 12:14:36 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Lukas Svaty 2017-05-10 13:54:44 UTC
verified in ovirt-engine-webadmin-portal-4.1.2.1-0.1.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.