Bug 1414433 - Trying to install mod_auth_kerb fails with "Requires: httpd-mmn = 20120211-x86-64"
Summary: Trying to install mod_auth_kerb fails with "Requires: httpd-mmn = 20120211-x8...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_auth_kerb
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 13:45 UTC by Thomas Schweikle
Modified: 2017-01-18 20:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 15:56:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Schweikle 2017-01-18 13:45:12 UTC
Description of problem:
Trying to install mod_auth_kerb fails:

# LANG=C yum install mod_auth_kerb
Loaded plugins: langpacks, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Resolving Dependencies
--> Running transaction check
---> Package mod_auth_kerb.x86_64 0:5.4-28.el7 will be installed
--> Processing Dependency: httpd-mmn = 20120211-x86-64 for package: mod_auth_kerb-5.4-28.el7.x86_64
--> Finished Dependency Resolution
Error: Package: mod_auth_kerb-5.4-28.el7.x86_64 (oraclelinux7-x86_64)
           Requires: httpd-mmn = 20120211-x86-64
           Installed: httpd-2.4.6-45.0.1.el7.x86_64 (@oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-17.0.1.el7.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-18.0.1.el7_0.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-19.0.1.el7_0.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-31.0.1.el7.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-31.0.1.el7_1.1.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-40.0.1.el7.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-40.0.1.el7_2.1.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
           Available: httpd-2.4.6-40.0.1.el7_2.4.x86_64 (oraclelinux7-x86_64)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Matching packages are there, but not regarded as being compatible. It turns out it is a space added to "20120211-x86-64". Comparison is therefor not with "20120211-x86-64" solely, but against "20120211-x86-64 ". It does not match. Cant install package.

Version-Release number of selected component (if applicable):
see above

How reproducible:
Always. Found bug with:
- Fedora 24,25,rawhide
- RHEL 7
- CentOS 7
- Oracle Linux 7

Steps to Reproduce:
1. Install OS, then install "yum install httpd"
2. Try to install mod_auth_kerb: "yum install mod_auth_kerb"

Actual results:
Install fails, because no compatible httpd install found available.

Expected results:
Just install module, because the installed httpd matches:
httpd-mmn = 20120211-x86-64 -> from Apache
httpd-mmn = 20120211-x86-64 -> from Module

Additional info:
Seems to compare:
httpd-mmn = "20120211-x86-64"  -> from Apache against
httpd-mmn = "20120211-x86-64 " -> from Module

These do not match. Think it is a bug within mod_auth_kerb-module rpm.

Comment 1 Joe Orton 2017-01-18 15:56:45 UTC
Non-Fedora packages don't install on Fedora.

Comment 2 Rob Crittenden 2017-01-18 20:10:17 UTC
I can't reproduce with F-25. To report a bug against Fedora you should include the output related to Fedora and not Oracle Linux.


Note You need to log in before you can comment on or make changes to this bug.