Bug 1414455 - removing disk in VM edit dialog causes UI error
Summary: removing disk in VM edit dialog causes UI error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.1.1
: 4.1.1
Assignee: jniederm
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 14:38 UTC by Lucie Leistnerova
Modified: 2017-04-21 09:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:36:24 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: blocker+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
ui_log (4.25 KB, text/plain)
2017-01-18 14:38 UTC, Lucie Leistnerova
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71283 0 master MERGED userportal: Remove disk confirmation doesn't fail 2017-01-27 15:52:11 UTC
oVirt gerrit 71388 0 ovirt-engine-4.1 MERGED userportal: Remove disk confirmation doesn't fail 2017-01-30 15:29:24 UTC

Description Lucie Leistnerova 2017-01-18 14:38:32 UTC
Created attachment 1242173 [details]
ui_log

Description of problem:
By trying to remove disk in edit dialog for VM UI error appears 'Exception caught: undefined' and user must reload the page.


Version-Release number of selected component (if applicable):
ovirt-engine-userportal-4.1.0-0.4.master.20170118090304.git86ab9ea.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. edit VM
2. click on '-' by the disk in General tab

Actual results: UI error


Expected results: confirm dialog pops up

Comment 4 Red Hat Bugzilla Rules Engine 2017-01-24 07:48:13 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Lucie Leistnerova 2017-02-15 12:48:36 UTC
removing disk in edit form on user portal works OK

verified in ovirt-engine-userportal-4.1.1-0.1.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.