Bug 1414459 - spacecmd softwarechannel_removesyncschedule unhandled internal exception
Summary: spacecmd softwarechannel_removesyncschedule unhandled internal exception
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks: sat580-low
TreeView+ depends on / blocked
 
Reported: 2017-01-18 14:46 UTC by Ales Dujicek
Modified: 2017-06-21 12:07 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-2.5.14-60
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:07:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ales Dujicek 2017-01-18 14:46:37 UTC
Description of problem:

there is unhandled exception when you try to remove channel-sych-schedule and it does not exist:

spacecmd {SSM:0}> softwarechannel_removesyncschedule channel-test
ERROR: redstone.xmlrpc.XmlRpcFault: unhandled internal exception: redstone.xmlrpc.XmlRpcFault: com.redhat.rhn.taskomatic.InvalidParamException: No such jobLabel


Version-Release number of selected component (if applicable):
spacecmd-2.5.0-7.el6sat.noarch

How reproducible:
always

Comment 1 Jan Dobes 2017-02-20 10:16:42 UTC
fixed in spacewalk master:

9ebb9cfcbc152e13328304b1a7e025a290700628

Comment 4 Lukáš Hellebrandt 2017-02-27 15:15:28 UTC
Verified with spacewalk-java-2.5.14-61.

Removing a nonexistent repo sync now does not throw any exception or warning at all. After consulting this with jdobes, I am verifying it as intended behavior.


Note You need to log in before you can comment on or make changes to this bug.