Bug 1414463 - During OSP10->OSP11 upgrade we need to delete the old hiera hooks
Summary: During OSP10->OSP11 upgrade we need to delete the old hiera hooks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Marios Andreou
QA Contact: Omri Hochman
URL:
Whiteboard:
: 1414058 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 15:06 UTC by Marius Cornea
Modified: 2017-05-17 19:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:40:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 424715 None None None 2017-01-24 18:12:58 UTC
OpenStack gerrit 435190 None None None 2017-03-21 18:32:38 UTC
Launchpad 1657175 None None None 2017-01-24 16:34:27 UTC

Description Marius Cornea 2017-01-18 15:06:59 UTC
Description of problem:
During OSP10->OSP11 upgrade we need to delete the old hiera hooks. 

In UpgradeInitCommand:

    rm -f /usr/libexec/os-apply-config/templates/etc/puppet/hiera.yaml
    rm -f /usr/libexec/os-refresh-config/configure.d/40-hiera-datafiles
    rm -f /etc/puppet/hieradata/*.yaml

Comment 2 Sofer Athlan-Guyot 2017-03-21 18:30:51 UTC
Landed a while back, moving this to POST.  I think it landed downstream, so we can close it.  Marius, can you confirm ?

Comment 3 Sofer Athlan-Guyot 2017-03-21 18:32:39 UTC
Adding ocata patch.

Comment 4 Sofer Athlan-Guyot 2017-03-21 18:34:20 UTC
*** Bug 1414058 has been marked as a duplicate of this bug. ***

Comment 5 Marius Cornea 2017-03-22 11:21:31 UTC
(In reply to Sofer Athlan-Guyot from comment #2)
> Landed a while back, moving this to POST.  I think it landed downstream, so
> we can close it.  Marius, can you confirm ?

Yes, this is fixed in the latest puddle.

Comment 7 errata-xmlrpc 2017-05-17 19:40:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.