Bug 1414475 - Hypervisor selection should be validated earlier in the process
Summary: Hypervisor selection should be validated earlier in the process
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.2
Assignee: Derek Whatley
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 15:39 UTC by Matt Reid
Modified: 2017-02-28 01:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:44:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Not nearly enough RAM (53.00 KB, image/png)
2017-01-18 15:39 UTC, Matt Reid
no flags Details
CFME doesn't require any resources (7.44 KB, image/png)
2017-01-18 15:45 UTC, Matt Reid
no flags Details
Selected system had 3.86 GB (20.39 KB, image/png)
2017-01-18 16:08 UTC, Matt Reid
no flags Details
This tooltip says hypervisor needs 4gb overhead (20.70 KB, image/png)
2017-01-18 16:11 UTC, Matt Reid
no flags Details
With more RAM, only seeing OCP node RAM reflected in usage (57.28 KB, image/png)
2017-01-18 16:13 UTC, Matt Reid
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Matt Reid 2017-01-18 15:39:25 UTC
Created attachment 1242200 [details]
Not nearly enough RAM

Description of problem:
If you manage to flip hypervisor and engine systems during RHV configuration, and proceed to OpenShift configuration, when you're hoping to put CFME on it afterwards, you end up with a sad error message.

I'm told that my available RAM is -0.1400000000000000012 GB. Not sure that number makes sense though, my guess was that it was subtracting CFME RAM requirements from the total the hypervisor had (which in a dev env, if you pick the engine vm, it's < 4 GB), but I thought CFME required a lot more RAM than that.

Regardless, it would make more sense to warn at hypervisor selection, if the system they've chosen doesn't meet the minimum hardware requirements for the rest of the products they're going to be deploying. We should know that a system with 4 GB RAM isn't going to cut it as the only hypervisor when I'm going to be setting up OCP and CFME a few steps later.

Version-Release number of selected component (if applicable):
1.1


Additional info:

Comment 2 Matt Reid 2017-01-18 15:45:11 UTC
Created attachment 1242203 [details]
CFME doesn't require any resources

Is the tooltip hooked up and working to report the CFME hardware requirements we're taking into account during this step so we don't overcommit on OCP nodes?

Comment 3 Matt Reid 2017-01-18 16:08:56 UTC
Created attachment 1242209 [details]
Selected system had 3.86 GB

Comment 4 Matt Reid 2017-01-18 16:11:23 UTC
Created attachment 1242212 [details]
This tooltip says hypervisor needs 4gb overhead

This tooltip is the only place I've seen us say that the hypervisor itself requires 4gb of overhead. Does overhead mean that it needs to have 4gb of unallocated ram?

This also says that CFME needs 0 GB RAM. When I choose a system that has a lot more ram, I only see the required RAM as 16 GB, 8 for each node, nothing for CFME, and nothing about hypervisor overhead.

Comment 5 Matt Reid 2017-01-18 16:13:06 UTC
Created attachment 1242213 [details]
With more RAM, only seeing OCP node RAM reflected in usage

On a hypervisor that has more RAM, the only things taking RAM seem to be the OCP nodes, 1 master and 1 worker, with 8 GB each. Still no RAM usage taken into account for CFME, and nothing about this 4 GB hypervisor overhead I saw on the previous error.

Comment 6 Derek Whatley 2017-01-19 16:21:37 UTC
Failed to reproduce the issue with CFME not requiring any resources in my dev environment. 

Matt: could you provide the exact sequence of events you performed in order to make this happen? What were the specs of the machines you originally selected for each role, and at what point did you flip them?

Comment 7 Matt Reid 2017-01-19 20:09:19 UTC
Provided more info over email and IRC. Seems like it might be related to refreshing the page.

Comment 8 Derek Whatley 2017-01-19 20:18:52 UTC
https://github.com/fusor/fusor/pull/1353/files

Created PR for fixing the CFME tooltip issue. Was able to reproduce the blank (zeroed) CFME tooltip by manually refreshing the page instead of navigating through the UI to get to the OCP node selection page. 

Also, with this fix, you shouldn't see the CFME tool-tip doubling up.

Comment 10 Tasos Papaioannou 2017-01-24 16:01:28 UTC
Verified on QCI-1.1-RHEL-7-20170123.t.0.

Comment 12 errata-xmlrpc 2017-02-28 01:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.