Bug 1414491 - [RFE] Insights does not load if the appliance is registered through command line
Summary: [RFE] Insights does not load if the appliance is registered through command line
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Red Hat Access
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Satyajit Bulage
URL:
Whiteboard: access
: 1427494 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 16:15 UTC by ldomb
Modified: 2020-12-14 08:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-18 13:26:09 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description ldomb 2017-01-18 16:15:27 UTC
Description of problem:
When subscribing cloudforms via command line insights does not show any subscribed hosts. If the appliance also gets registered via UI insights starts working. 

Version-Release number of selected component (if applicable):
5.7.0.17.20161219135818_725f92f 

How reproducible:


Steps to Reproduce:
1.subscription-manager repos --enable=rhel-7-server-rpms --enable=cf-me-5.7-for-rhel-7-rpms --enable=rhel-server-rhscl-7-rpms --enable=rhel-7-server-rpms
2. yum install redhat-access-insights
3. redhat-access-insights --register
4. Go to the insights tab nothing shows up. 
5. Register the appliance via UI -> Red Hat Updates
add the following channels 
rhel-7-server-rpms cf-me-5.7-for-rhel-7-rpms rhel-server-rhscl-7-rpms rhel-7-server-rpms

Wait until it registers
6. Go back to the insights tab and you should know see insights working.

Actual results:
Insights does not show up if the appliance is registered and subscribed via command line

Expected results:
Insights should show up if the appliance is registered and subscribed via command line

Additional info:

Comment 2 Dave Johnson 2017-01-19 16:55:37 UTC
Currently this requires the user to subscribe the appliance through the UI.  When this happens, the credentials are added to the database, which is what access insights uses for the integration.  

Marking as a RFE, as there most likely is a need to do it through the command line for multi-appliance automated deployments.  This still wouldn't address the issue where a user uses subscription-manager from the command line though.  That would require some time of watchdog process perhaps.

Laurent, any issues with me turning this into a RFE to add subscription management support to appliance_console_cli.

Comment 3 ldomb 2017-01-27 17:48:59 UTC
Works for me. As long as it can be automated I am find with it.

Comment 4 luke couzens 2017-03-02 09:52:36 UTC
*** Bug 1427494 has been marked as a duplicate of this bug. ***

Comment 13 luke couzens 2018-01-30 14:41:51 UTC
I still see this issue in 5.8.3.1 and 5.9.0.18

Comment 15 Lindani Phiri 2018-01-30 15:07:52 UTC
@sbulage  - can i have access to a reproducer appliance?
We added a fall back that checks the file system as a fallback when the db is not updated.

Comment 18 Josh Carter 2018-09-18 13:26:09 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms RFE(Request for Enhancement) backlog in order to improve our responsiveness to customers. We are closing any requests for versions no longer within full support(link below to the lifecycle) or that do not have a clear spot on the product roadmap. We are committing to better management of the backlog as we move forward. If you have an RFE that you still have a strong business case for, please open a new BZ against the currently supported version 4.6.

Lifecycle page: https://access.redhat.com/support/policy/updates/cloudforms

If you have any concerns about this, please let us know.

Thanks and regards!”


Note You need to log in before you can comment on or make changes to this bug.