Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414493 - Turkish Q Keyboard special characters does not work in Wayland session
Summary: Turkish Q Keyboard special characters does not work in Wayland session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libxkbcommon
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1389968 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 16:16 UTC by Akın Ömeroğlu
Modified: 2017-01-21 17:32 UTC (History)
8 users (show)

Fixed In Version: libxkbcommon-0.7.1-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 18:07:42 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 774374 0 None None None 2017-01-18 16:16:30 UTC

Description Akın Ömeroğlu 2017-01-18 16:16:31 UTC
Description of problem:

Hello,

I am using an updated version of Fedora 25. If I login to system with wayland, the special characters of Turkish (ı İ Ğ Ü ü ğ ) and Alt_Gr button does not work. 

This bug is filed under https://bugzilla.redhat.com/show_bug.cgi?id=1389968 but there is no updates. 

I searched this bug in upstream and found that this bug was also filled in gnome and closed by mutter developers with RESOLVED NOTGNOME flag.

Gnome adress that this problem related to libxkbcommon in their bugzilla. libxkbcommon upstream also filed an issue[1] related this problem

It seems that this commit[2] solves problem and as far as I see there is no stable release which includes this  patch.

Could you kindly include this patch in libxkbcommon package if this is "the solution"

[1]: https://github.com/xkbcommon/libxkbcommon/issues/42 
[2]:https://github.com/xkbcommon/libxkbcommon/commit/b5586a6c4294b46eb23d1fc527ff63dcd27e23ac

Thanks for your effort.

Version-Release number of selected component (if applicable):

0.6.1

How reproducible:

Always

Steps to Reproduce:
1. Set keyboard map to Turkish Q
2. Reboot system and login with Wayland
3. Try to type Turkish special characters ı İ and try to type other characters with Alt_Gr button like @ $ ¾

Actual results:

I can not type this characters if I login with Wayland

Expected results:

Keyboard must work without a problem

Comment 1 Piotr Drąg 2017-01-18 17:34:07 UTC
libxkbcommon's maintainer is planning a new release very soon: https://github.com/xkbcommon/libxkbcommon/issues/42#issuecomment-273543312

Hopefully it will get to Fedora just as quickly. :)

Comment 2 Piotr Drąg 2017-01-18 19:18:30 UTC
libxkbcommon-0.7.1 is available now.

Comment 3 Piotr Drąg 2017-01-19 00:21:51 UTC
The fixed release has been submitted for testing: https://bodhi.fedoraproject.org/updates/FEDORA-2017-766da1b4ef

It would be great if you could test it and give appropriate karma.

Comment 4 Fedora Update System 2017-01-19 02:14:52 UTC
libxkbcommon-0.7.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-766da1b4ef

Comment 5 Fedora Update System 2017-01-19 09:12:41 UTC
libxkbcommon-0.7.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-766da1b4ef

Comment 6 Akın Ömeroğlu 2017-01-19 09:17:44 UTC
Hello,

This update solves bug and works perfect. I gave appropriate karma in bodhi. It seems that there is a problem in my connection and I gave same karma more than one time. Sorry for the mess and thanks for your effort to solve this issue.

Btw, could you kindly other related bug as a duplicate and inform the that bug CC list.

Thanks again...

Comment 7 Peter Hutterer 2017-01-19 09:51:19 UTC
done! :)

Comment 8 Peter Hutterer 2017-01-19 09:51:33 UTC
*** Bug 1389968 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2017-01-20 18:07:42 UTC
libxkbcommon-0.7.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 ersan 2017-01-21 17:32:03 UTC
Problem solved.
Thank you


Note You need to log in before you can comment on or make changes to this bug.