Bug 1414497 - OSP10->OSP11 upgrade fails during nova-manage db online_data_migrations
Summary: OSP10->OSP11 upgrade fails during nova-manage db online_data_migrations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-messaging
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Victor Stinner
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 16:25 UTC by Marius Cornea
Modified: 2017-05-17 19:40 UTC (History)
17 users (show)

Fixed In Version: python-oslo-messaging-5.16.0-0.20161222235050.ea61a81.el7ost
Doc Type: Bug Fix
Doc Text:
The Oslo Messaging did not initialize its configuration properly. As a result, the 'nova-manage' client failed during startup. The error has been fixed. Now 'nova-manage' starts correctly.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:40:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 403924 None None None 2017-01-30 12:22:08 UTC

Description Marius Cornea 2017-01-18 16:25:58 UTC
Description of problem:
On the node which runs the nova-api service the following error shows up when running nova-manage db online_data_migrations:

[root@overcloud-serviceapi-0 heat-admin]# nova-manage db online_data_migrations
Traceback (most recent call last):
  File "/bin/nova-manage", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/nova/cmd/manage.py", line 1430, in main
    config.parse_args(sys.argv)
  File "/usr/lib/python2.7/site-packages/nova/config.py", line 50, in parse_args
    rpc.init(CONF)
  File "/usr/lib/python2.7/site-packages/nova/rpc.py", line 74, in init
    TRANSPORT = create_transport(get_transport_url())
  File "/usr/lib/python2.7/site-packages/nova/rpc.py", line 154, in get_transport_url
    return messaging.TransportURL.parse(CONF, url_str, TRANSPORT_ALIASES)
  File "/usr/lib/python2.7/site-packages/oslo_messaging/transport.py", line 398, in parse
    url = url or conf.transport_url
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2271, in __getattr__
    raise NoSuchOptError(name)
oslo_config.cfg.NoSuchOptError: no such option transport_url in group [DEFAULT]


Version-Release number of selected component (if applicable):
latest osp11 puddle tht with https://review.openstack.org/#/c/405241/ applied

How reproducible:
2/2

Steps to Reproduce:
1. Run the upgrade prcedure

Actual results:
Upgrade fails while upgrading the role which contains the nova api service

Expected results:
Upgrade should pass

Additional info:

Comment 1 Marius Cornea 2017-01-18 16:54:43 UTC
Workaround: update python-oslo-messaging to python-oslo-messaging-5.16.0-0.20161222235050.ea61a81.el7ost on the nodes running nova-api

Comment 3 Sven Anderson 2017-01-27 15:38:34 UTC
The shipped python-oslo-messaging must be upgraded to include this change:

https://review.openstack.org/#/c/403924/

Comment 9 errata-xmlrpc 2017-05-17 19:40:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.