Bug 1414509 - Avoid forcing AllowClusterWithVirtGlusterEnabled=False
Summary: Avoid forcing AllowClusterWithVirtGlusterEnabled=False
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.1.1
: ---
Assignee: Simone Tiraboschi
QA Contact: SATHEESARAN
URL:
Whiteboard: integration
Depends On:
Blocks: Gluster-HC-2 1380743
TreeView+ depends on / blocked
 
Reported: 2017-01-18 17:09 UTC by Simone Tiraboschi
Modified: 2017-04-25 01:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, AllowClusterWithVirtGlusterEnabled was explicitly set to false at setup to prevent users from having an unsupported hyper-converged deployment by mistake. Now, AllowClusterWithVirtGlusterEnabled is set to true by default to allow for hyper-converged deployments. (BZ#1414509)
Clone Of:
Environment:
Last Closed:
oVirt Team: Integration


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1007 normal SHIPPED_LIVE rhevm-setup-plugins bug fix and enhancement update 2017-04-18 20:17:52 UTC

Description Simone Tiraboschi 2017-01-18 17:09:10 UTC
Description of problem:
In the past AllowClusterWithVirtGlusterEnabled was explicitly set to False at setup time to prevent the users from trying an unsupported hyper-converged deployment by mistake.
Now, due to the hyperconverged effort, we have to remove that lock.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine with rhevm-appliance
2. check the initial value of AllowClusterWithVirtGlusterEnabled with engine-config
3.

Actual results:
AllowClusterWithVirtGlusterEnabled is initially False

Expected results:
AllowClusterWithVirtGlusterEnabled is initially True

Additional info:

Comment 2 SATHEESARAN 2017-03-07 10:16:41 UTC
Tested with RHV 4.1.1.3

'AllowClusterWithVirtGlusterEnabled' is set to 'true' by default

[root@ ~]# engine-config -g AllowClusterWithVirtGlusterEnabled
AllowClusterWithVirtGlusterEnabled: true version: general


Note You need to log in before you can comment on or make changes to this bug.