Bug 1414515 - [RFE] Provide Framework to document all the knobs in t-h-t -- like an API doc
Summary: [RFE] Provide Framework to document all the knobs in t-h-t -- like an API doc
Keywords:
Status: CLOSED DUPLICATE of bug 1410668
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 14.0 (Rocky)
Hardware: aarch64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Ben Nemec
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1442136
TreeView+ depends on / blocked
 
Reported: 2017-01-18 17:20 UTC by Hugh Brock
Modified: 2020-11-18 17:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-18 17:52:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 253638 0 None MERGED Sample environment generator 2020-11-18 17:51:30 UTC

Description Hugh Brock 2017-01-18 17:20:54 UTC
We need a very detailed documentation set that described the
location and usage of pretty much every parameter you could set in a
Heat environment for t-h-t -- in other words, almost an API doc for
t-h-t.

This would be useful for way more than this one
customer, and I wonder if we already have something like it. If not, I
would think it would be a really helpful thing for customers and even
for casual community users. Ideally it would be automated in some way, as described in this thread:

http://post-office.corp.redhat.com/archives/rh-openstack-dev/2017-January/msg00181.html

Comment 2 Jaromir Coufal 2017-06-13 14:07:04 UTC
Due to missed milestone deadline, pushing dev target to early Queens M-1 and therefor productization of the feature to OSP13.

Development in the upstream master will continue through out the time of OSP12 cycle with lower priority than OSP12 feature.

Comment 3 Jaromir Coufal 2017-06-13 14:09:47 UTC
Removing "triaged" keyword to review the RFE when planning for OSP13.

Comment 18 Kevin Carter 2020-11-18 17:52:21 UTC

*** This bug has been marked as a duplicate of bug 1410668 ***


Note You need to log in before you can comment on or make changes to this bug.