Bug 1414526 - Ceilometer events off by default but events are still saved to mongodb without TTL set
Summary: Ceilometer events off by default but events are still saved to mongodb withou...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 12.0 (Pike)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard: scale_lab
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 18:20 UTC by Alex Krzos
Modified: 2018-02-05 19:04 UTC (History)
11 users (show)

Fixed In Version: openstack-ceilometer-9.0.2-0.20170925173740.1057885.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 21:02:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Alex Krzos 2017-01-18 18:20:46 UTC
Description of problem:
CeilometerStoreEvents defaults to off but events are still saved to mongodb.  This causes mongodb to grow in size until the disk runs out because the event TTL is set to -1.  store_events doesn't matter because events_dispatcher=database is configured by default thus causing events to be saved into mongodb without any ttl.


Version-Release number of selected component (if applicable):
OSP10 - Newton GA build

How reproducible:
Always

Steps to Reproduce:
1. Deploy according to docs and view size of the event collection in mongodb
2.
3.

Actual results:
the event collection will grow in size as ceilometer stores events

Expected results:
If CeilometerStoreEvents is set to false, events should not be stored.  


Additional info:
CeilometerStoreEvents set to false [0]
CeilometerStoreEvents maps to store_events under agent notification configuration [1]
events_dispatcher defaults to database in ceilometer puppet installer [2]
event_time_to_live defaults to -1 in ceilometer puppet installer [3]


This is due to CeilometerStoreEvents maps to store_events under agent_notification configuration section.

[0] https://github.com/openstack/tripleo-heat-templates/blob/stable/newton/puppet/services/ceilometer-base.yaml#L43
[1] https://github.com/openstack/tripleo-heat-templates/blob/stable/newton/puppet/services/ceilometer-base.yaml#L100
[2] https://github.com/openstack/puppet-ceilometer/blob/stable/newton/manifests/collector.pp#L50
[3] https://github.com/openstack/puppet-ceilometer/blob/fc4a0fd5100128280703dbb3f8e109fb9393a2d0/manifests/init.pp#L235

There is likely some parameters we can pass into the deploy command to mitigate this issue.

Comment 1 Julien Danjou 2017-03-06 14:57:34 UTC
I think this is something that ought to be fixed in Puppet recipes for Ceilometer. I'm assigning this to you Prad, but feel free to bump it elsewhere if it's wrong. :)

Comment 2 Pradeep Kilambi 2017-04-18 17:12:18 UTC
This should be fixed with collector deprecated.

Comment 3 Thierry Vignaud 2017-06-29 09:07:12 UTC
Hi
Can you either:
- add the gerrit ID of the actual change so that we can doble check if we did got the actual fix?
- or check if our current downstream build is OK?
Thanks

Comment 9 errata-xmlrpc 2017-12-13 21:02:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.