Bug 1414528 - Base Runtime FTBFS: gnome-doc-utils-0.20.10-9.fc25
Summary: Base Runtime FTBFS: gnome-doc-utils-0.20.10-9.fc25
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Deadline: 2017-02-01
Product: Fedora
Classification: Fedora
Component: gnome-doc-utils
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BaseRuntimeFTBFS
TreeView+ depends on / blocked
 
Reported: 2017-01-18 18:33 UTC by Merlin Mathesius
Modified: 2017-01-19 13:59 UTC (History)
4 users (show)

Fixed In Version: gnome-doc-utils-0.20.10-10.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 06:39:01 UTC
Type: Bug


Attachments (Terms of Use)
proposed patch to correct FTBFS issue (1.34 KB, patch)
2017-01-18 18:36 UTC, Merlin Mathesius
no flags Details | Diff

Description Merlin Mathesius 2017-01-18 18:33:12 UTC
Subject: Base Runtime FTBFS: gnome-doc-utils-0:0.20.10-9.fc25

Description of problem:
When attempting to rebuild portions of the frozen package set of Fedora 25 for the Base Runtime effort, we discovered that gnome-doc-utils fails to build due to a missing BuildRequires on python due to python being removed from the default buildroot. This issue also manifests itself in Rawhide where only python3 is present in the buildroot.

Version-Release number of selected component (if applicable):
gnome-doc-utils-0:0.20.10-9.fc25

How reproducible:
Every time

Steps to Reproduce (rawhide):
1. fedpkg clone redland
2. fedpkg switch-branch master
3. fedpkg mockbuild

Actual results (rawhide):

SyntaxError: Missing parentheses in call to 'print'

Actual results (base-runtime):

configure: error: no suitable Python interpreter found


Expected results:
Successful build of the package.

Additional info:
This is needed as part of the Base Runtime effort.

Attached is a patch that adds the missing BuildRequires on python.

Please apply the patch or respond with a reason it should not be applied within two weeks. After that time, a provenpackager will go ahead and apply it.

Comment 1 Merlin Mathesius 2017-01-18 18:36:09 UTC
Created attachment 1242254 [details]
proposed patch to correct FTBFS issue

Comment 2 Merlin Mathesius 2017-01-18 19:52:28 UTC
Apologies for the cut/paste errors in the description. The NVR of the package should be gnome-doc-utils-0.20.10-9.fc25, and step 1 to reproduce the problem should be "fedpkg clone gnome-doc-utils".

Comment 3 Kalev Lember 2017-01-19 06:39:01 UTC
Thanks, applied the patch and building for rawhide. Do you need it for F25 too?

Comment 4 Merlin Mathesius 2017-01-19 13:59:29 UTC
Thank you for another quick fix! As long as the patch has been merged for F25 (which it is), we are good.


Note You need to log in before you can comment on or make changes to this bug.