Bug 1414533 - Gnome-shell crashes upon startup
Summary: Gnome-shell crashes upon startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gjs
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 18:52 UTC by Phea Duch
Modified: 2017-01-19 11:25 UTC (History)
7 users (show)

Fixed In Version: mozjs31-31.5.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 11:25:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Phea Duch 2017-01-18 18:52:29 UTC
Description of problem:

Gnome-shell/GDM crashes upon startup with latest GJS (1.47.4-1.fc26). Problem does not occur if I downgrade to previous version gjs-1.47.0-2.fc26.

Version-Release number of selected component (if applicable):

GJS 1.47.4-1.fc26
gnome-shell-3.23.2-3.fc26

How reproducible:

Everytime.

Steps to Reproduce:
1. Boot into gnome or launch gnome from terminal.
2.
3.

Actual results:

Crash.

Expected results:

No error.

Additional info:

$> coredumpctl

Stack trace of thread 1311:
                #0  0x00007f72ed27430b raise (libc.so.6)
                #1  0x00007f72ed27622a abort (libc.so.6)
                #2  0x00007f72ed2ba350 __libc_message (libc.so.6)
                #3  0x00007f72ed35d307 __fortify_fail (libc.so.6)
                #4  0x00007f72ed35d2d0 __stack_chk_fail (libc.so.6)
                #5  0x00007f72f694857f n/a (libgjs.so.0)
                #6  0x00007fffb0e8d8f0 n/a (n/a)

           PID: 1273 (gnome-shell)
           UID: 42 (gdm)
           GID: 42 (gdm)
        Signal: 6 (ABRT)

Comment 1 Kevin Fenzi 2017-01-18 19:59:07 UTC
Seeing this here as well.

Comment 2 Mikko Tiihonen 2017-01-19 10:13:07 UTC
Also happens here. Journal says:
*** stack smashing detected ***: /usr/bin/gnome-shell terminated

This is quite critical because one cannot boot a system with this update (since gdm is started by default) unless manually adding some systemd rescue commands to kernel boot configuration.

Comment 3 Kalev Lember 2017-01-19 11:25:08 UTC
Thanks, the crash should be fixed with mozjs31-31.5.0-1.fc26 build.


Note You need to log in before you can comment on or make changes to this bug.