Bug 1414552 - Membership Learn More http link is faulty
Summary: Membership Learn More http link is faulty
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.z
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 20:16 UTC by Jonas Nordell
Modified: 2017-01-31 20:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The path for the 3.4 documentation links in the console was incorrect. Consequence: A redirect had to be added to the documentation site so the incorrect paths would resolve until the path could be fixed. Fix: The documentation links have the correct path. Result: Documentation links in the console go directly to the correct paths without needing the redirect.
Clone Of:
Environment:
Last Closed: 2017-01-31 20:20:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0218 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.4.1.2 bug fix update 2017-02-01 01:18:20 UTC

Description Jonas Nordell 2017-01-18 20:16:09 UTC
Description of problem:

When I click my "Learn More" link under "resources >> membership" I  get redirected to 

https://docs.openshift.com/container_platform/3.4/architecture/additional_concepts/authorization.html#roles

But that throws a 404 because it should be

https://docs.openshift.com/container-platform/3.4/architecture/additional_concepts/authorization.html#roles

Same goes for all "Learn More" links under the "membership" tab

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

The redirect should have the correct URL

Additional info:

Comment 1 Jessica Forrester 2017-01-18 21:27:12 UTC
This is actually a problem on all of our targeted doc links for 3.4, only the default link has the correct path. We will try to get a redirect added for the path so that all the links work.

Comment 2 Jessica Forrester 2017-01-18 21:37:29 UTC
Additionally the links will be fixed in the source in 3.4.1, the fix has been merged.

Comment 3 N. Harrison Ripps 2017-01-18 23:25:28 UTC
Redirect has been added to send container_platform => container-platform

Comment 4 Jessica Forrester 2017-01-18 23:51:18 UTC
We will leave this bug to track the fix going into 3.4.1, moving to MODIFIED since the fix is merged to that branch.

Comment 5 Yanping Zhang 2017-01-20 10:11:39 UTC
Checked on OCP 3.4.1.0, now when hover on "Learn more", in the browser bottem, it shows "https://docs.openshift.com/container_platform/3.4/architecture/additional_concepts/authorization.html#roles", but if click on "Learn more", will open the correct link: https://docs.openshift.com/container-platform/3.4/architecture/additional_concepts/authorization.html#roles

Is it the expected fix?

Comment 6 Jessica Forrester 2017-01-20 13:41:25 UTC
The redirect is expected until the fix is in a 3.4.1 build.  This fix is not yet in a build.  With the fix the links should all be container-platform

Comment 8 Yanping Zhang 2017-01-26 02:02:59 UTC
Checked on OCP v3.4.1.2, "Learn More" and all other links are point to right url now: https://docs.openshift.com/container-platform/3.4/……
The bug has been fixed, so move it to Verified.

Comment 10 errata-xmlrpc 2017-01-31 20:20:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0218


Note You need to log in before you can comment on or make changes to this bug.