Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414555 - The on-demand download policy can't handle filters with wildcards
Summary: The on-demand download policy can't handle filters with wildcards
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.2.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 20:22 UTC by gpizarro
Modified: 2019-08-12 16:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-18 18:55:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description gpizarro 2017-01-18 20:22:46 UTC
Description of problem:

When using a filter like nagios-plugins-* with the on-demand download policy the packages aren't available.


Version-Release number of selected component (if applicable):

6.2.6


Steps to Reproduce:

1. Add a filter with a wildcard to on-demand repo.
2. Publish and promote CV.
3. Try to install package on a host.


Actual results:

Unable to install package, yum fails with error.


Expected results:

To be able to install the packages that fall under the scope of the filter.


Additional info:

Packages with full names in the filters for that repo worked fine. The same filter in a repo with immediate policy works too.

Comment 2 Justin Sherrill 2017-07-06 13:47:49 UTC
I cannot seem to reproduce this issue and there isn't much information here.  

1) What error are you seeing on the yum side?
2) do the packages show up as being in that content view version in the UI?

Comment 3 Justin Sherrill 2017-07-18 18:55:57 UTC
Since its been a week, I'm going ahead and closing this.  In your situation i wonder if on_demand was working at all?  

If you are still able to produce, feel free to reopen.
Thanks


Note You need to log in before you can comment on or make changes to this bug.