Bug 1414571 - Mysql 5.7(latest) image pod does not start
Summary: Mysql 5.7(latest) image pod does not start
Keywords:
Status: CLOSED DUPLICATE of bug 1414576
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Honza Horak
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On: 1414576
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 21:11 UTC by Vikas Laad
Modified: 2017-02-17 18:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1414576 (view as bug list)
Environment:
Last Closed: 2017-02-17 18:55:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vikas Laad 2017-01-18 21:11:11 UTC
Description of problem:
When latest image is used for Mysql dc, mysql pod errors out with following error. This happens when using PV.

root@ip-172-31-41-173: ~/svt/openshift_scalability # oc logs -n eap64-mysql0         eap-app-mysql-1-k89cp   
---> 19:28:51     Processing MySQL configuration files ...
---> 19:28:51     Initializing database ...
---> 19:28:51     Running mysqld --initialize-insecure ...
2017-01-18T19:28:51.134868Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2017-01-18T19:28:51.144948Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
2017-01-18T19:28:51.144970Z 0 [ERROR] Aborting

Version-Release number of selected component (if applicable):
openshift v3.5.0.5+8f2840d
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0


How reproducible:
Always

Steps to Reproduce:
1. Create an app using mysql using PV
2. Make sure to use the latest image tag for mysql dc
3. See the error in the mysql pod logs

Actual results:
Pod doesnt come up and shows above error, when changing the image tag to 5.6 works and pod comes up.

Expected results:
Pod should start without any error.

Additional info:

Comment 1 Ben Parees 2017-01-18 21:20:52 UTC
This needs to be investigated by the SCL team, i've created bug https://bugzilla.redhat.com/show_bug.cgi?id=1414576 for them to own.  This bug will remain open as a tracker only.

Comment 2 Ben Parees 2017-02-17 18:55:47 UTC
we're just going to track this in 141576, so closing this bug.

*** This bug has been marked as a duplicate of bug 1414576 ***


Note You need to log in before you can comment on or make changes to this bug.