Bug 1414573 - 'systemctl restart messagebus sssd oddjobd' results in slow logins and NetworkManager errors
Summary: 'systemctl restart messagebus sssd oddjobd' results in slow logins and Networ...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 21:15 UTC by SHAURYA
Modified: 2018-05-30 16:36 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-19 21:21:54 UTC
sshaurya: needinfo+


Attachments (Terms of Use)

Description SHAURYA 2017-01-18 21:15:35 UTC
Description of problem:

One of our puppet modules triggers a service refresh when the sssd.conf file changes. It currently restarts messagebus, sssd and oddjobd. On RHEL7 this results on two issues:

1. SSH connections become really, really slow
2. NetworkManager start spewing errors.

I was able to resolve both issue with systemctl restart systemd-logind NetworkManager, but I am wondering a couple things:

1. How *should* we be doing this, i.e. sssd.conf changes and what services should be restarted. Just sssd or more?
2. It looks like the errors from NetworkManager could be a bug:

Jan 17 10:19:30 iam-mon-ld001 NetworkManager[35599]: <warn>  [1484666370.0263] bus-manager: could not create org.freedesktop.DBus proxy (Error calling StartServiceByName for org.freedesktop.DBus: The connection is closed); only the private D-Bus socket will be available
Jan 17 10:19:30 iam-mon-ld001 NetworkManager: (NetworkManager:35599): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: The connection is closed


Version-Release number of selected component (if applicable):

[root@localhost sosreport-iam-mon-ld001.tam.private-20170117102252] # cat installed-rpms | grep -i networkmanager
NetworkManager-1.4.0-13.el7_3.x86_64                        Thu Dec  8 20:16:29 2016
NetworkManager-config-server-1.4.0-13.el7_3.x86_64          Thu Dec  8 20:18:02 2016
NetworkManager-libnm-1.4.0-13.el7_3.x86_64                  Thu Dec  8 20:16:11 2016
NetworkManager-team-1.4.0-13.el7_3.x86_64                   Thu Dec  8 20:16:46 2016
NetworkManager-tui-1.4.0-13.el7_3.x86_64                    Thu Dec  8 20:16:46 2016


How reproducible:

Check in description

Actual results:

slowness of network manager

Expected results:

slowness of network manager should not be there


Additional info:

Comment 1 Thomas Haller 2017-01-19 09:17:44 UTC
Restarting "messagebus" means to restart dbus.

In general, many components don't handle restart of dbus properly, so if you try to restart the dbus daemon, you effectively would have to restart a range of service -- which amounts to a reboot.

NetworkManager doesn't support restarting dbus. Afterwards it will not reconnect to the message-bus and is effectively unreachable.
When restarting dbus, you also need to restart NetworkManager.
This is a missing feature, but of relatively high effort with low priority.
Especially, we hoped that kdbus would solve this by always having the bus available.

Why do you want to restart dbus? Maybe you should just reload its configuration instead?

Comment 4 Sergio Monteiro Basto 2018-05-30 16:36:19 UTC
after systemctl restart NetworkManager 
stopping show errors messages in /var/log/messages


Note You need to log in before you can comment on or make changes to this bug.