Bug 1414575 - "service foreman-proxy start" when the service is running deletes pidfile and causes "service stop" wont work
Summary: "service foreman-proxy start" when the service is running deletes pidfile and...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule
Version: 6.2.8
Hardware: All
OS: Linux
unspecified
high
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 21:19 UTC by Pavel Moravec
Modified: 2020-04-15 15:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-18 15:25:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Moravec 2017-01-18 21:19:06 UTC
Description of problem:
Starting foreman-proxy service on RHEL6 / via initscripts twice in a row causes service's pidfile deletion. _that_ causes "service foreman-proxy stop" wont halt the process.

Reasoning:

start() method in /etc/init.d/foreman-proxy does not check for pidfile presence and directly launches new instance of the process. "service" command returns success (sic!) but the new instance detects it cant bind to port 9090 so it shutdowns. The new instance of the process first overwrites pidfile and then it deletes it (since shutdown of that PID happened).


Version-Release number of selected component (if applicable):
any, incl. 1.13.2-1.el6


How reproducible:
100%


Steps to Reproduce:
(Sat6 on RHEL6):
(all services stopped - or at least foreman-proxy one)

service foreman-proxy start
sleep 10
service foreman-proxy start
sleep 10
service foreman-proxy stop

(meantime, monitor if such process is running, and content of /var/run/foreman-proxy/foreman-proxy.pid)

(optionally, replace either "service .." call by katello-service command)



Actual results:
- pidfile is deleted during 2nd sleep
- process will be running at the end


Expected results:
- pidfile contains pid of running process
- process is stopped at the end


Additional info:

Comment 4 pm-sat@redhat.com 2017-01-24 13:13:12 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 5 Dmitri Dolguikh 2017-01-24 13:38:26 UTC
This is a downstream-only issue, as Upstream doesn't package init scripts anymore. Opened a PR: https://gitlab.sat.lab.tlv.redhat.com/satellite6/satellite-packaging/merge_requests/74

Comment 8 Bryan Kearney 2017-09-18 15:25:45 UTC
I do not see these being backported into 6.2.z. There are clones tracking these issues for other versions of satellite.


Note You need to log in before you can comment on or make changes to this bug.