Bug 1414619 - [IntService_public_295] Ansible var name is not consistant
Summary: [IntService_public_295] Ansible var name is not consistant
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Bruno Barcarol Guimarães
QA Contact: Peng Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 03:10 UTC by Peng Li
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the documentation cited a variable with the wrong name. Consequence: the playbook would not work if the instructions were followed. Fix: correct the name in the documentation. Result: instructions are now correct.
Clone Of:
Environment:
Last Closed: 2017-04-12 18:48:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Peng Li 2017-01-19 03:10:29 UTC
Description of problem:
Try the new Metrics install way using Ansible, failed at step task TASK [openshift_metrics : Check that hawkular_metrics_hostname is set] *********
task path: openshift-ansible/roles/openshift_metrics/tasks/install_metrics.yaml:2

var name here is 'openshift_metrics_hawkular_hostname', in the README.md the var name is 'openshift_metrics_hostname', thus user follow doc and run ansible task fail.


Version-Release number of selected component (if applicable):
openshift v3.5.0.6+87f6173

How reproducible:
always

Steps to Reproduce:
1. prepare the inventory file

[oo_first_master]
$MASTER ansible_user=root ansible_ssh_user=root ansible_ssh_private_key_file="/home/penli/.ssh/libra.pem" openshift_public_hostname=$MASTER

[oo_first_master:vars]
deployment_type=openshift-enterprise
openshift_release=v3.5.0
openshift_metrics_install_metrics=true

openshift_metrics_hostname=hawkular-metrics.$SUBDOMAIN
openshift_metrics_project=openshift-infra

openshift_metrics_image_prefix=registry.ops.openshift.com/openshift3/
openshift_metrics_image_version=3.5.0

2. git clone https://github.com/openshift/openshift-ansible.git

3. ansible-playbook -vvv -i ~/inventory   playbooks/common/openshift-cluster/openshift_metrics.yml

4. task fail and abort.


Expected results:
install successfully.

Additional info:
Ansible execution log attached.

Comment 3 Peng Li 2017-01-20 05:30:37 UTC
verified on master branch

Comment 6 errata-xmlrpc 2017-04-12 18:48:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0903


Note You need to log in before you can comment on or make changes to this bug.