Bug 1414640 - [IntService_public_324]Unable to establish ssh connection for ansible user while gathering openShift logging facts
Summary: [IntService_public_324]Unable to establish ssh connection for ansible user wh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.z
Assignee: ewolinet
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 06:05 UTC by Xia Zhao
Modified: 2017-10-25 13:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-10-25 13:00:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible_full_logs (50.80 KB, text/plain)
2017-01-19 06:05 UTC, Xia Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3049 0 normal SHIPPED_LIVE OpenShift Container Platform 3.6, 3.5, and 3.4 bug fix and enhancement update 2017-10-25 15:57:15 UTC

Description Xia Zhao 2017-01-19 06:05:18 UTC
Created attachment 1242375 [details]
ansible_full_logs

Description of problem:
Deploy logging with ansible, failed while establishing ssh connection for ansible user while gathering openShift logging facts:
TASK [openshift_logging : Gather OpenShift Logging Facts] **********************
task path: /home/xiazhao/openshift-ansible/roles/openshift_logging/tasks/install_logging.yaml:2
Using module file /home/xiazhao/openshift-ansible/roles/openshift_logging/library/openshift_logging_facts.py
...
<$master-public-dns> ESTABLISH SSH CONNECTION FOR USER: root
<$master-public-dns> SSH: EXEC ssh -C -o ControlMaster=auto -o ControlPersist=60s -o 'IdentityFile="/home/xiazhao/cfile/libra.pem"' -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=root -o ConnectTimeout=10 -o ControlPath=/home/xiazhao/.ansible/cp/ansible-ssh-%h-%p-%r -tt $master-public-dns '/bin/sh -c '"'"'/usr/bin/python /root/.ansible/tmp/ansible-tmp-1484802323.29-59427329366493/openshift_logging_facts.py; rm -rf "/root/.ansible/tmp/ansible-tmp-1484802323.29-59427329366493/" > /dev/null 2>&1 && sleep 0'"'"''
fatal: [$master-public-dns]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "invocation": {
        "module_args": {
            "admin_kubeconfig": "/tmp/openshift-logging-ansible-z5QVAS/admin.kubeconfig", 
            "oc_bin": "oc", 
            "openshift_logging_namespace": "xiazhao"
        }, 
        "module_name": "openshift_logging_facts"
    }, 
    "msg": "'kibana'"
}
    to retry, use: --limit @/home/xiazhao/openshift-ansible/playbooks/common/openshift-cluster/openshift_logging.retry

PLAY RECAP *********************************************************************
$master-public-dns : ok=11   changed=1    unreachable=0    failed=1 

Version-Release number of selected component (if applicable):
# openshift version
openshift v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0

How reproducible:
Always

Steps to Reproduce:
1. prepare the inventory file

[oo_first_master]
$master-public-dns ansible_user=root ansible_ssh_user=root ansible_ssh_private_key_file="~/cfile/libra.pem" openshift_public_hostname=$master-public-dns

[oo_first_master:vars]
deployment_type=openshift-enterprise
openshift_release=v3.5.0
openshift_logging_install_logging=true

openshift_logging_kibana_hostname=kibana.$subdomain
public_master_url=https://$master-public-dns:8443

openshift_logging_image_prefix=$ops-registry
openshift_logging_image_version=3.5.0

openshift_logging_namespace=xiazhao

2. git clone https://github.com/openshift/openshift-ansible
3. ansible-playbook -vvv -i ~/inventory   playbooks/common/openshift-cluster/openshift_logging.yml

Actual results:
Failed at TASK [openshift_logging : Gather OpenShift Logging Facts] 

Expected results:
Should complete successfully

Additional info:
Full log attached

Comment 1 Xia Zhao 2017-01-19 08:50:39 UTC
Blocks logging installation with ansible on OCP 3.5.0, not yet get it workarounded, keyword "TestBlocker" added.

Comment 5 Xia Zhao 2017-01-20 03:25:47 UTC
Verified with the latest playbook on openshift-ansible, issue has been fixed well. Thanks!

# openshift version
openshift v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0

Comment 7 errata-xmlrpc 2017-10-25 13:00:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049


Note You need to log in before you can comment on or make changes to this bug.