Bug 1414658 - ha-agents should log INFO just to logfile by default
Summary: ha-agents should log INFO just to logfile by default
Keywords:
Status: CLOSED DUPLICATE of bug 1376559
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha
Version: 4.0.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Martin Sivák
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 07:35 UTC by Germano Veit Michel
Modified: 2017-01-20 01:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 00:53:07 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)

Description Germano Veit Michel 2017-01-19 07:35:52 UTC
Description of problem:

/var/log/messages gets lot's of these. This makes it harder for an admin to check /var/log/messages.

Jan 16 06:55:05 rhevh1 ovirt-ha-agent: INFO:ovirt_hosted_engine_ha.lib.ovf.ovf_store.OVFStore:Found OVF_STORE: imgUUID:4a2d9b88-fee1-49c9-b83e-e1660374aa09, volUUID:17577203-d8b4-4753-b136-72076d9cf570
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:ovirt_hosted_engine_ha.broker.listener.ConnectionHandler:Connection established
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:ovirt_hosted_engine_ha.broker.listener.ConnectionHandler:Connection closed
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:ovirt_hosted_engine_ha.broker.listener.ConnectionHandler:Connection established
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:ovirt_hosted_engine_ha.broker.listener.ConnectionHandler:Connection closed
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:ovirt_hosted_engine_ha.broker.listener.ConnectionHandler:Connection established
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:ovirt_hosted_engine_ha.broker.listener.ConnectionHandler:Connection closed
Jan 16 06:55:05 rhevh1 ovirt-ha-broker: INFO:mem_free.MemFree:memFree: 2662

By default, these should be just on /var/log/ovirt-hosted-engine-ha/broker.log.

Perhaps just log just ERROR to syslog?

Related:
/etc/ovirt-hosted-engine-ha/agent-log.conf
/etc/ovirt-hosted-engine-ha/broker-log.conf

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.0.4-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install HE
2. see /var/log/messages in the host once ha starts.

Comment 1 Martin Sivák 2017-01-19 09:00:14 UTC
This looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1376559 which was fixed in 4.0.6. Are you sure you do not have any .rpmnew files laying around?

Comment 2 Germano Veit Michel 2017-01-20 00:53:07 UTC
(In reply to Martin Sivák from comment #1)
> This looks like a duplicate of
> https://bugzilla.redhat.com/show_bug.cgi?id=1376559 which was fixed in
> 4.0.6. Are you sure you do not have any .rpmnew files laying around?

Hi Martin,

Well, it was fixed. I thought I was on latest version before filling this, now I realized I was not, and it's a bit weird.

There is something wrong my all my RHV-H hosts... they should be on latest 4.0.6 but there are all stuck in 4.0.5 besides have been "upgraded" from the manager to latest version...

They all have the latest 4.0.6 update rpm

redhat-virtualization-host-image-update-4.0-20170104.1.el7_3.noarch

But none of them actually applied it (4 Hosts). All upgraded from the manager and the thinpools have just the older image.

I'll try to figure out what happened...

All good on 2.0.6, closing.

*** This bug has been marked as a duplicate of bug 1376559 ***

Comment 3 Germano Veit Michel 2017-01-20 01:24:09 UTC
Turns out BZ #1374545 seems to break RHVH 4.0 upgrade due to the return value of vgs during imgbase upgrade.


Note You need to log in before you can comment on or make changes to this bug.