Bug 141468 - can't connect to htt_server
can't connect to htt_server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks: 137149
  Show dependency treegraph
 
Reported: 2004-12-01 06:50 EST by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: im-sdk-12.1-10.EL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-05 23:40:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backported patch from upstream (512 bytes, patch)
2004-12-01 07:08 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2004-12-01 06:50:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
Even if htt_server runs without the tcp socket, it gets 'Denied the access from localhost.' when the applications is realized.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add ALL:ALL into /etc/hosts.deny
2.restart htt_server
3.run any applications
  

Actual Results:  Denied the access from localhost.


Expected Results:  the applications should be allowed to connect to.

Additional info:

This problem happens because htt_server *always* ask tcp_wrapper whether or not the host is allowed to connect to. but tcp_wrapper isn't needed for the unix domain socket anyway.
Comment 1 Akira TAGOH 2004-12-01 07:08:02 EST
Created attachment 107708 [details]
backported patch from upstream
Comment 2 Leon Ho 2004-12-01 07:16:27 EST
Customers will always have a secure configuration and it may block iiimf access
even iiimf is unix domain by default. The patch is very small and low risk.
Comment 3 Leon Ho 2004-12-01 10:16:52 EST
It is built in -10.EL now
Comment 4 Lawrence Lim 2004-12-05 23:40:54 EST
Confirm fixed in im-sdk-12.1-10.EL.


Thanks.

Note You need to log in before you can comment on or make changes to this bug.