Bug 1414706 - [RFE] openshift-ansible should configure default loggingPublicURL when openshift_master_logging_public_url not set
Summary: [RFE] openshift-ansible should configure default loggingPublicURL when opensh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.z
Assignee: ewolinet
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On: 1419838
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 10:23 UTC by Gaoyun Pei
Modified: 2017-12-14 21:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: When installing logging, we now update the master config and add 'loggingPublicURL'. Reason: Without 'loggingPublicURL' being set, a user would not see a link to view historical logs from the console. Result: After installing logging, the 'loggingPublicURL' and its value is added to the master config and then restarted so that when logging into the console you can see the link to view historical logs.
Clone Of:
Environment:
Last Closed: 2017-12-14 21:01:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3438 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix and enhancement update 2017-12-15 01:58:11 UTC

Description Gaoyun Pei 2017-01-19 10:23:27 UTC
Description of problem:
When we enable logging deployment in ansible inventory without setting openshift_master_logging_public_url, openshift-ansible wouldn't configure loggingPublicURL in master-config.yaml.

But in metrics deployment, it will set https://hawkular-metrics.{{openshift_master_default_subdomain}}/hawkular/metrics as metricsPublicURL when no openshift_hosted_metrics_public_url specified, installer should also do some similar behavior for logging deployment.


Version-Release number of selected component (if applicable):
openshift-ansible-3.4.55-1.git.0.9cb1f40.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Enable openshift_hosted_logging_deploy=true, trigger an installation.
2.After installation, check master-config.yaml


Actual results:
No loggingPublicURL in master-config.yaml


Expected results:
openshift-ansible could configure https://kibana.{{ openshift_master_default_subdomain }} as loggingPublicURL in master-config.yaml when logging deployment enabled but without openshift_master_logging_public_url specified.

Additional info:

Comment 1 Scott Dodson 2017-01-24 18:42:03 UTC
If this isn't fixed in the 3.5 rewrite we should make sure it is.

Comment 3 Gaoyun Pei 2017-02-06 10:14:29 UTC
Test this bug with openshift-ansible-3.5.3-1.git.0.80c2436.el7.noarch.rpm.

With the following options setting in ansible inventory, run installer
openshift_master_default_subdomain=0206-4-e.qe.rhcloud.com
openshift_hosted_logging_deploy=true

After installation, check master-config.yaml
[root@ip-172-18-1-150 ~]# grep loggingPublicURL /etc/origin/master/master-config.yaml
  loggingPublicURL: https://kibana.0206-4-e.qe.rhcloud.com

As BZ#1419026 was blocking ha master cluster setup for 3.5, will also verify whether it works well for ha masters after BZ#1419026 verified.

Comment 4 Gaoyun Pei 2017-02-07 08:45:01 UTC
Logging deployment was blocked in openshift-ansible-3.5.4-1, will verify this bug after BZ#1419838 fixed.

Comment 5 Gaoyun Pei 2017-02-17 09:39:36 UTC
Verify this bug with openshift-ansible-3.5.10-1.git.0.ba66b63.el7.noarch.rpm.

For non-ha master env and ha master env, once enable openshift_hosted_logging_deploy=true and also with openshift_master_default_subdomain set in ansible inventory, loggingPublicURL will be configured in all masters' /etc/origin/master/master-config.yaml.

Comment 8 errata-xmlrpc 2017-12-14 21:01:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3438


Note You need to log in before you can comment on or make changes to this bug.