Bug 141473 - Slow Upload with CPU100%, from LAN Cilent.
Summary: Slow Upload with CPU100%, from LAN Cilent.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ftp   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Raszyk
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-01 12:56 UTC by TaKa Yamada
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 15:12:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description TaKa Yamada 2004-12-01 12:56:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I don't know what is wrong.
Before I reinstall fedora 3, I get 9000KB/s with CPU less than 20%
usage with vsftpd, 

After I reinstalled, with same setting, 
I get 500KB/s with CPU100% when uploading files from LAN Cilent.
I tried vsftpd, proftpd but same result,

I didnt change anything just reinstall and update.

Any one has same problem or is this happens only me?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.just upload file from FTP client.(LAN)
2.
3.
    

Expected Results:  should be about 9000KB/s and less than CPUusage20%

Additional info:

Comment 1 Sitsofe Wheeler 2004-12-01 18:35:57 UTC
What does top say is using all the CPU?

Comment 2 TaKa Yamada 2004-12-02 00:26:22 UTC
I meant
When I upload files from WIndows Cilent(I tryed many cilent softwares with pasv 
on/off)

the Fedora Core 3's CPU Usage is 100percent when I'm uploading,

Comment 3 Thomas Woerner 2004-12-02 10:32:27 UTC
You are uploading files to the linux host?
Then this bug should be filed against the ftp server.

Comment 4 Sitsofe Wheeler 2004-12-02 10:46:56 UTC
Comment #2:
OK but you don't say WHAT process top claims is using all the CPU. Is it the FTP
server? Or is all CPU disappearing inside system I/O? Could you attach the
around the first 20 lines of top to this bug?

Comment 5 Petr Raszyk 2005-08-15 15:12:29 UTC
This is not a bug in Linux-ftp-client.Your ftp client is a MS Windows executable.
We could not reproduce your issue using Linux-ftp-client <---> Linux-ftp-server.
We did not receive 'the first 20 lines of top' to continue with your issue as
a Linux-ftp-server-bug.


Note You need to log in before you can comment on or make changes to this bug.