Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414756 - master service can't be started when setting "openshift_buildoverrides_force_pull=true"
Summary: master service can't be started when setting "openshift_buildoverrides_force_...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 11:26 UTC by Gan Huang
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-09 04:11:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Gan Huang 2017-01-19 11:26:44 UTC
Description of problem:
Config "openshift_buildoverrides_force_pull=true" in inventory hosts file, installer would fail at task "openshift_examples : Import RHEL streams" due to master service already failed during installation.

Version-Release number of selected component (if applicable):
openshift-ansible-3.5.1-1.git.0.e23e9bf.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.cat inventory_hosts

<--snip-->
openshift_buildoverrides_force_pull=true
<--snip-->

2.Run BYO playbook
3.

Actual results:

1) Installer failed at task:
TASK [openshift_examples : Import RHEL streams] ********************************
Thursday 19 January 2017  11:00:55 +0000 (0:00:00.080)       0:09:27.999 ****** 
failed: [openshift-131.lab.sjc.redhat.com] (item=/usr/share/openshift/examples/image-streams/image-streams-rhel7.json) => {"changed": false, "cmd": ["oc", "create", "-n", "openshift", "-f", "/usr/share/openshift/examples/image-streams/image-streams-rhel7.json"], "delta": "0:00:00.299864", "end": "2017-01-19 06:00:55.830511", "failed": true, "failed_when_result": true, "item": "/usr/share/openshift/examples/image-streams/image-streams-rhel7.json", "rc": 1, "start": "2017-01-19 06:00:55.530647", "stderr": "The connection to the server openshift-131.lab.sjc.redhat.com:8443 was refused - did you specify the right host or port?", "stdout": "", "stdout_lines": [], "warnings": []}
failed: [openshift-131.lab.sjc.redhat.com] (item=/usr/share/openshift/examples/image-streams/dotnet_imagestreams.json) => {"changed": false, "cmd": ["oc", "create", "-n", "openshift", "-f", "/usr/share/openshift/examples/image-streams/dotnet_imagestreams.json"], "delta": "0:00:00.312209", "end": "2017-01-19 06:00:56.649140", "failed": true, "failed_when_result": true, "item": "/usr/share/openshift/examples/image-streams/dotnet_imagestreams.json", "rc": 1, "start": "2017-01-19 06:00:56.336931", "stderr": "The connection to the server openshift-131.lab.sjc.redhat.com:8443 was refused - did you specify the right host or port?", "stdout": "", "stdout_lines": [], "warnings": []}

2) Check master service
Jan 19 06:21:40 openshift-131.lab.sjc.redhat.com atomic-openshift-master[16619]: F0119 06:21:40.880774   16619 start_master.go:724] Could not start build controller: could not load config file "/tmp/admission-plugin-config352180080" due to an error: error reading config: [pos 32]: json: decode bool: got first char "

3) Check master config
# cat /etc/origin/master/master-config.yaml |grep force
        forcePull: 'true'

4) Remove additional single quotes in master-config.yaml, then master service was able to restart successfully.
# cat /etc/origin/master/master-config.yaml |grep force
        forcePull: true


Expected results:


Additional info:

Comment 2 Wang Haoran 2017-02-03 13:52:04 UTC
verified with :
Verified with version:
openshift v3.5.0.14+20b49d0
kubernetes v1.5.2+43a9be4
etcd 3.1.0


Note You need to log in before you can comment on or make changes to this bug.