Bug 1414782 - Add logs to selfheal code path to be helpful for debug
Summary: Add logs to selfheal code path to be helpful for debug
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 12:37 UTC by Susant Kumar Palai
Modified: 2017-05-30 18:38 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 18:38:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Susant Kumar Palai 2017-01-19 12:37:28 UTC
Description of problem:
Currently there is no helpful logs in selfheal code path. 

This bugs is used to track the patch for adding logs to selfheal code path.

Comment 1 Worker Ant 2017-01-19 13:43:43 UTC
REVIEW: http://review.gluster.org/16040 (dht/cluster: add logs to fix-layout code path) posted (#6) for review on master by Susant Palai (spalai@redhat.com)

Comment 2 Worker Ant 2017-01-20 10:50:02 UTC
COMMIT: http://review.gluster.org/16040 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 71913a3058cdf2978fc948304a361748dc8fdbc0
Author: Susant Palai <spalai@redhat.com>
Date:   Tue Dec 6 15:34:39 2016 +0530

    dht/cluster: add logs to fix-layout code path
    
    Currently there is no helpful log in fix-layout code path. Adding
    the logs to be helpful for debugging fix-layout failures.
    
    BUG: 1414782
    Change-Id: I61c29ceedcaa2e235fa7be99866709d6ca6de3ae
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/16040
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Worker Ant 2017-03-02 09:06:47 UTC
REVIEW: https://review.gluster.org/16826 (dht/cluster: add logs to fix-layout code path) posted (#1) for review on release-3.10 by Poornima G (pgurusid@redhat.com)

Comment 4 Shyamsundar 2017-05-30 18:38:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.