Bug 1414794 - [RFE] provide a way for the user to scale and prepare gluster nodes from cockpit UI.
Summary: [RFE] provide a way for the user to scale and prepare gluster nodes from cock...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: ---
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.2.2
: 0.11.17
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-3 1523598 1523610
TreeView+ depends on / blocked
 
Reported: 2017-01-19 13:11 UTC by RamaKasturi
Modified: 2018-05-23 08:20 UTC (History)
7 users (show)

Fixed In Version: cockpit-ovirt-0.11.17-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1523598 (view as bug list)
Environment:
Last Closed: 2018-05-23 08:20:03 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2?
sabose: blocker?
rule-engine: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1546085 0 high CLOSED error in app.js after save action in edit mode of gdeployConfig.conf in gluster based self hosting engine wizard. 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1547453 0 high CLOSED create one VDO volume when encryption & dedupe enabled on few or all the bricks on the same device 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1552526 0 high CLOSED lvmcache size value is missing units in the generated gdeploy config file 2021-02-22 00:41:40 UTC
oVirt gerrit 88032 0 ovirt-4.2 MERGED Gluster Management Dashboard 2018-03-01 22:33:57 UTC
oVirt gerrit 88060 0 master ABANDONED Gluster Management Dashboard - Conflicts Resolved and changes made 2018-02-22 07:04:24 UTC
oVirt gerrit 88075 0 master ABANDONED Manage Gluster - Create Volume 2018-03-01 05:08:59 UTC
oVirt gerrit 88319 0 master MERGED Gluster Management merge with create volume 2018-03-01 22:34:10 UTC
oVirt gerrit 88320 0 master MERGED Implemented Expand Cluster Feature 2018-03-01 22:34:35 UTC
oVirt gerrit 88364 0 master MERGED Create and Run Expand Cluster Config File 2018-03-01 22:35:10 UTC
oVirt gerrit 88372 0 ovirt-4.2 POST Gluster Management Dashboard 2018-03-01 22:33:50 UTC
oVirt gerrit 88373 0 ovirt-4.2 MERGED Gluster Management merge with create volume 2018-03-01 22:34:23 UTC
oVirt gerrit 88374 0 ovirt-4.2 MERGED Implemented Expand Cluster Feature 2018-03-01 22:34:53 UTC
oVirt gerrit 88375 0 ovirt-4.2 MERGED Create and Run Expand Cluster Config File 2018-03-01 22:35:22 UTC
oVirt gerrit 88430 0 ovirt-4.2 MERGED Allowing user to enter host for expand cluster 2018-03-08 13:54:22 UTC
oVirt gerrit 88682 0 ovirt-4.2 POST Allowing user to enter host for expand cluster 2018-03-08 13:54:15 UTC
oVirt gerrit 88778 0 master MERGED Gluster Management - Bug Fixes 2018-03-12 14:34:29 UTC
oVirt gerrit 88825 0 ovirt-4.2 MERGED Gluster Management - Bug Fixes 2018-03-12 17:46:12 UTC
oVirt gerrit 88950 0 master MERGED Fixed Run Gluster Wizard issue 2018-03-14 07:00:15 UTC
oVirt gerrit 88954 0 ovirt-4.2 MERGED Fixed Run Gluster Wizard issue 2018-03-14 07:11:14 UTC

Internal Links: 1546085 1547453 1552526

Description RamaKasturi 2017-01-19 13:11:05 UTC
Description of problem:
As of now user cannot prepare gluster nodes from cockpit UI for scaling. User has to do the following tasks manually on each node and it has to be added to the cluster one after the other.

   1)  Install all the required packages in case of RHEL deployments,configuring other components in the host like,
adding the required channels , setting up NTP, setting up glusterfs slice, etc

    3) Add all the three nodes one after the other to UI

    4) Prepare bricks from UI on all the three nodes.

    5) Now create an arbiter / replicate volume from UI.
    
    6) since virt group has only few options, user has to manually go and add other options which are required.

provide a way for the user to perform above actions from cockpit ui.

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.3.el7ev.noarch

How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:
As of now user cannot prepare gluster nodes for scaling from cockpit UI.

Expected results:
There should be a provision for the user to scale and prepare gluster nodes from cockpit UI. 

Additional info:

Comment 1 SATHEESARAN 2017-01-20 06:18:56 UTC
(In reply to RamaKasturi from comment #0)
> Description of problem:
> As of now user cannot prepare gluster nodes from cockpit UI for scaling.
> User has to do the following tasks manually on each node and it has to be
> added to the cluster one after the other.
> 
>    1)  Install all the required packages in case of RHEL
> deployments,configuring other components in the host like,
> adding the required channels , setting up NTP, setting up glusterfs slice,
> etc
> 
>     3) Add all the three nodes one after the other to UI
> 
>     4) Prepare bricks from UI on all the three nodes.
> 
>     5) Now create an arbiter / replicate volume from UI.
>     
>     6) since virt group has only few options, user has to manually go and
> add other options which are required.
> 
> provide a way for the user to perform above actions from cockpit ui.
> 

In the above mentioned steps, only step-1 & step-6 is not that easy for Grafton (HC) users.
Step-1 requires cockpit-gdeploy for sure. Step-3, 4, 5 could be done after the node is added in RHV UI.

Again step-6 requires some more help to set the required volume options on the volume.

Comment 3 SATHEESARAN 2018-05-15 10:05:29 UTC
Tested with cockpit-ovirt-dashboard-0.11.24.

After HE deployment, 'Manage Gluster' button is available, clicking on which takes to 'Expand Cluster' option

Comment 4 Sandro Bonazzola 2018-05-23 08:20:03 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.