Bug 1414795 - Tag missing in registry.access.redhat.com 3.4.0 for logging-deployer
Summary: Tag missing in registry.access.redhat.com 3.4.0 for logging-deployer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Logging
Version: 3.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
: 1414820 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 13:11 UTC by Kim Borup
Modified: 2017-07-26 15:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 12:50:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2883401 None None None 2017-01-20 19:15:31 UTC

Description Kim Borup 2017-01-19 13:11:43 UTC
Description of problem:
When doing a fresh install, trying to pull down logging-deployer during install times ends up with a problem as tag: 3.4.0 gives a 404. 

Version-Release number of selected component (if applicable):
3.4

How reproducible:
All the time

Steps to Reproduce:
1.Setup hosted logging in configuration file, before running advances installer. 
2.Run the installer. 
3.

Actual results:
logging deployer trying to pull logging-deployer:3.4.0 

error: Import failed (InternalError): Internal error occurred: error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""
      Less than a second ago


Expected results:
Installation of logging deployer.

Additional info:
latest tag works.

Comment 1 Kim Borup 2017-01-19 13:32:37 UTC
setting openshift_hosted_logging_deployer_version=latest in hosts file, so we take the latest instead of the missing 3.4.0 seems to work.

Comment 2 Troy Dawson 2017-01-19 14:28:20 UTC
Starting with 3.4, logging-deployer, and meterics-deployer, started being built with the openshift3/ose group of images.  As a result, they took on the ose style of versioning, and has the following tags.

openshift3/logging-deployer:latest
openshift3/logging-deployer:v3.4
openshift3/logging-deployer:v3.4.0.39
openshift3/logging-deployer:v3.4.0.39-2

I'm not saying this is right or wrong, just what happened and what the end result is.

For the current work around, I recommend you set openshift_hosted_logging_deployer_version=v3.4 instead of latest.

I will let others say what we should do for this.  Since all the images were tagged this way through all of our testing, I'm pretty sure there was a plan.

Comment 3 Michal Fojtik 2017-01-19 14:50:53 UTC
*** Bug 1414820 has been marked as a duplicate of this bug. ***

Comment 4 Troy Dawson 2017-01-19 21:30:38 UTC
I have discovered that during our testing phase, we did have the 3.4.0 tags.
I apologize for this oversite.
I am working on getting the 3.4.0 tags onto the released images.

Comment 5 Troy Dawson 2017-01-20 22:09:19 UTC
3.4.0 tag has successfully been applied to registry.access.redhat.com/openshift3/metrics-deployer and registry.access.redhat.com/openshift3/logging-deployer

Please try again and let us know how it goes.

Comment 6 Peng Li 2017-01-22 06:21:15 UTC
Verified, both images can be pulled.

# docker pull registry.access.redhat.com/openshift3/metrics-deployer:3.4.0
Trying to pull repository registry.access.redhat.com/openshift3/metrics-deployer ... 
sha256:123825bc4576cbc4b2a699ccbc6e61666d9b5cb76a544104010298e9efbb1f7e: Pulling from registry.access.redhat.com/openshift3/metrics-deployer
7bd78273b666: Pull complete 
c196631bd9ac: Pull complete 
2a244ccc5a0c: Pull complete 
95e389f1da09: Pull complete 
13c112094d90: Pull complete 
Digest: sha256:123825bc4576cbc4b2a699ccbc6e61666d9b5cb76a544104010298e9efbb1f7e
Status: Downloaded newer image for registry.access.redhat.com/openshift3/metrics-deployer:3.4.0

# docker pull registry.access.redhat.com/openshift3/logging-deployer:3.4.0
Trying to pull repository registry.access.redhat.com/openshift3/logging-deployer ... 
sha256:713ef15ecf90e8942d842e62237a6d9feba6da2e85343de6a59563a4267b864e: Pulling from registry.access.redhat.com/openshift3/logging-deployer
7bd78273b666: Already exists 
c196631bd9ac: Already exists 
2a244ccc5a0c: Already exists 
95e389f1da09: Already exists 
79e9f429cb6a: Pull complete 
Digest: sha256:713ef15ecf90e8942d842e62237a6d9feba6da2e85343de6a59563a4267b864e
Status: Downloaded newer image for registry.access.redhat.com/openshift3/logging-deployer:3.4.0


Note You need to log in before you can comment on or make changes to this bug.