Bug 1414857 - upgrading from 1.3 to 1.4 fails because of wrong flag --drain on oc adm manage-node
Summary: upgrading from 1.3 to 1.4 fails because of wrong flag --drain on oc adm manag...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Installer
Version: 3.x
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 15:30 UTC by Grant Shipley
Modified: 2017-03-30 12:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-30 12:55:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Grant Shipley 2017-01-19 15:30:59 UTC
Description of problem:
The upgrade from 1.3 to 1.4 using ansible playbook fails because --drain is not an option for 'oc adm manage-node' but is oc adm drain

Version-Release number of selected component (if applicable):
1.4

How reproducible:
every time

Steps to Reproduce:
1. ansible-playbook -i inventory.erb openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_4/upgrade.yml

Actual results:
fatal: [console.techdope.io -> console.techdope.io]: FAILED! => {"changed": true, "cmd": ["/usr/local/bin/oc", "adm", "manage-node", "192.168.0.139", "--drain", "--force"], "delta": "0:00:00.197877", "end": "2017-01-19 10:09:45.916133", "failed": true, "rc": 1, "start": "2017-01-19 10:09:45.718256", "stderr": "Error: unknown flag: --drain\n\n\nUsage:\n  oc adm manage-node [options]

Expected results:
According to:
https://github.com/openshift/openshift-ansible/blob/def9d435ef60b1f11c29db2fc98fe266bbd4041d/roles/openshift_facts/library/openshift_facts.py#L870

It should be evacuate for 1.4 and not drain.  In any case, it shouldn't be --drain but instead oc adm drain

Additional info:

Comment 1 Scott Dodson 2017-03-30 12:55:31 UTC
This was fixed in https://github.com/openshift/openshift-ansible/pull/3459


Note You need to log in before you can comment on or make changes to this bug.